Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

very long query

roger-u's profile image roger-u posted 2 months ago in General Permalink

Hi,

i have a big table with over 5 million rows.. one column is a text column and is not indexed.. But i accidentally clicked the column heading and now it's spending forever trying to do that sort.

My mistake of course, but there is no way to cancel this. The STOP button does nothing, and if i force HeidiSql to terminate it remember that sort option and immediately tries it again as soon as i select the Data tab.

Eventually it sorts itself out of course ... but it would be nice to be able to terminate it.

Roger

ansgar's profile image ansgar posted 2 months ago Permalink

Yes, that is still a problem. You may remove the filter as long as you did not activate the "Data" tab, via right-click on the table in the tree, then click "Clear data tab filter".

But that only applies to a filter, not to the sorted columns.

To remove the sorting, you may use regedit.exe

  • exit all HeidiSQL instances
  • start regedit.exe
  • navigate to key: HKEY_CURRENT_USER\SOFTWARE\HeidiSQL\Servers\<YourSessionName>\<Database>|<Table>
  • remove the Sort string value
  • restart HeidiSQL

And yes, this should be doable in HeidiSQL itself. I still need a simple idea for how to provide such a reset action.

roger-u's profile image roger-u posted 2 months ago Permalink

why not simply(!) make "Clear data tab filter" clear all the Sort as well. Maybe change that menu option caption.. And in future it could clear any other similar options, including the Show all option (if that sticks)

ansgar's profile image ansgar posted 2 months ago Permalink

Yes, that would indeed be the simplest.

I somehow thought there could be a better approach, more noticable to the user, as you were not the first one overseeing this menu item.

BubikolRamios's profile image BubikolRamios posted 2 months ago Permalink

Preview:

...... I just noticed: Sort warning on grid rows: 1000

it works in query tab, not in data tab.

v. ...6097

aplay that to data tab also and problem soolved I think. Also I think there should be some default setting for Sort warning on grid rows - I think it is not right now

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.