Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Importing a CSV File

lvogl's profile image lvogl posted 1 month ago in General Permalink

Hello,

whenever I try to import a csv File into Heidi it says:

/ SQL Error (1265): Data truncated for column 'Twist_Improvment' at row 1 /

The column Twist_Improvment is the last column. It then only imports the first row of my file.

Here is the beginning of my csv: 20170227T131732;7.0;7.0;TCM430K;ANSI4CL150(AW);123.67;292.7;0.0418;0.0357;1.17;0.1255;0.1926;0.65 20140623T145315;10000.0;508.0;TCM325;FemaleThreadG0.5(FA);144.42;319.83;0.3645;0.0169;21.56;0.0343;0.024;1.3 20140623T150708;10001.0;509.0;TCM325;FemaleThreadG0.5(FA);143.78;318.62;0.3932;0.0146;26.85;0.03;0.0173;1.7

I appreciate any help!

ansgar's profile image ansgar posted 1 month ago Permalink

You may have set wrong control characters. Please post a screenshot of the dialog and the settings you are using.

lvogl's profile image lvogl posted 1 month ago Permalink

I attached the pictures.

Thank you for your response!

2 attachment(s):
  • Settings
  • Log
ansgar's profile image ansgar posted 1 month ago Permalink

Ok, I can see your csv file has fields delimited by semicolon. But does it also have Windows CR/LF linebreaks (\r\n)? It may have Linux LF linebreaks (\n) instead. If so, you should set this in the dialog correctly.

You should look at the file with Notepad++ or some similar text editor. Even Notepad nowadays displays the type of linebreaks:

Description

lvogl's profile image lvogl posted 1 month ago Permalink

Thank you! Now it works.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.