Changes to "SQL Editing" keyboard shortcuts mostly don't stick

Niko-O's profile image Niko-O posted 2 years ago in HeidiSQL portable Permalink

I want to remote the "Ctrl+Y" shortcut from "Delete line" and instead make "Redo" be that. Buuuuut any changes I make to those two settings get reverted when I click OK. I get a lot of /* Could not apply SynEdit keystroke shortcut "<the shortcut I tried>" (or secondary: "") to ecRedo. Shortcut already exists. [...] kind of errors in the log.
Removing any shortcut from the "SQL Editing" section does not stick.
Changing shortcuts from the "SQL Editing" section to something else usually works, but not for the Redo, also not for Undo, also there are two entries for Undo and Redo.
Changing and removing shortcuts from other sections does work.

Any suggestions are welcome. It's extremely frustrating to undo a bit too far, and then irrecoverably delete code by deleting lines instead of undoing the undo.

Where does HeidiSQL store the keyboard settings? I can't see anything in portable_settings.txt that would indicate keyboard settings. The registry contains "HKCU\SOFTWARE\HeidiSQL Portable 25248" with some "Shortcut" values, but only when the program runs, which is very weird.

giang.nguyen's profile image giang.nguyen posted 2 years ago Permalink

Hello, this issue also bugs me a lot. It would be great if we can change the shortcut of redo command. Besides I reconized that there are two Undo and Redo commands in shortcut settings (s. screenshot). I think the second group is the right one, although I tried to change both of them but no success.

I still want to say thanks to the creator to make such a great application. It helps me a lot in my work.

Best regards

1 attachment(s):
  • 2021-12-15_08-32-56
SinChan4896's profile image SinChan4896 posted 12 months ago Permalink

I am still getting the same error when I change the "Delete Line" to None and change the second "Redo" to Ctrl + Y

Error: / Could not apply SynEdit keystroke shortcut "Ctrl+Y" (or secondary: "Ctrl+Y") to ecRedo. Shortcut already exists. Please go to Tools > Preferences > Shortcuts to change this settings. /

Version: 12.1

Please login to leave a reply, or register at first.