Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Wrong font size

cesarm's profile image cesarm posted 3 months ago in General Permalink

Whenever I switch Heidi between monitors, the font sizes are skewed.

On the left grid, the font is too big. In the query grid, the font is very small and in the results too. The naming of the query tabs is also too big.

The only way to get back to normal is to close the app and open it again.

Could you fix this, please?

1 attachment(s):
  • Screenshot_1
ansgar's profile image ansgar posted 3 months ago Permalink

Font sizes should follow the DPI setting on your screen, at least with the newer build which you obviously are using. Which DPI scaling is set on that screen? (in percent normally)

Further things:

  • font size in query editor and result grid is customizable. Both can be increased/decreased when using Ctrl Mousewheel
  • Did you set a custom GUI font/size probably? Try resetting it to default system font in Tools > Preferences > General:

Description

cesarm's profile image cesarm posted 3 months ago Permalink

I have 2 monitors with different resolutions.

When I drag Heidi's window from one monitor to another, the fonts are misconfigured.

It seems that the responsive function fails at this time

ansgar's profile image ansgar posted 3 months ago Permalink

Did you read my reply?

Can you probably look up whether you have set a custom font size (see screenshot above)

cesarm's profile image cesarm posted 3 months ago Permalink

Yes, I read. The configuration is default.

I tried to choose a font and re-tested, but the problem persists.

Whenever I drag Heidi from one screen to another, the responsive leaves the fonts unconfigured.

ansgar's profile image ansgar posted 3 months ago Permalink

Ok, then which values has your DPI setting, in this Windows dialog:

Description

cesarm's profile image cesarm posted 3 months ago Permalink

I'm from Brazil.

I'm sending screenshot of my screens settings.

Thanks.

2 attachment(s):
  • Screen1
  • Screen2
ansgar's profile image ansgar posted 3 months ago Permalink

Thanks, that shows me your larger screen runs with 150% DPI setting, and you're on Windows 11.

I just did the same (scale to 150%) in a HyperV virtual machine, but this looks quite ok with the default font size setting:

Description

Could you please make a screenshot of the "General" tab in your HeidiSQL preferences (like in my screen above).

cesarm's profile image cesarm posted 3 months ago Permalink

Yes. Sure. Thanks.

1 attachment(s):
  • Untitled
cesarm's profile image cesarm posted 3 months ago Permalink

Another...

1 attachment(s):
  • Screenshot_1
ansgar's profile image ansgar posted 3 months ago Permalink

Hm, that screenshot is taken from a Windows 10 system, right? The checkboxes tell me so. I'm asking because your above screenshot with the DPI setting is likely from a different system (Windows 11?):

Description

Are you perhaps running HeidiSQL in a virtual box?

I need to know the scaling percentage of the screen/system where you run HeidiSQL.

cesarm's profile image cesarm posted 3 months ago Permalink

I'm sorry. You're right.

My laptop has Windows 11.

The problem happens when I access my Desktop via Remote Desktop.

My Desktop has Windows 10.

I am attaching the video settings of my Desktop in Windows 10, even though I think that, because it is remote access, the settings that will apply will be from the Notebook in Windows 11.

1 attachment(s):
  • Untitled
ansgar's profile image ansgar posted 3 months ago Permalink

Yes that makes more sense now, thanks for clarifying.

As far as I know the scaling is not overtaken from the host, so you can indeed have a different scaling in your remote session.

It would be the best to try that without RemoteDesktop. I suspect your Desktop has a scale setting of 250%?

cesarm's profile image cesarm posted 3 months ago Permalink

Unfortunately I need Remote Desktop to access certain databases (security issue).

I never had this problem. From some of Heidi's recent new updates this issue started happening.

That's why I contacted you. Hoping that you could sort this out.

1 attachment(s):
  • Screenshot_1
cesarm's profile image cesarm posted 3 months ago Permalink

Is there anything you can do to stop the problem from happening again?

Thank you so much for always responding promptly and cordially.

ansgar's profile image ansgar posted 3 months ago Permalink

Not that I know of. I cannot reproduce the issue here, with a DPi setting of 225% (which is roughly the one your screen shows). You could as said try without RemoteDesktop, to help debugging. I guess it will look different then, but I can't be sure.

Of course you could downgrade your HeidiSQL to the last release. But the next release will have that DPI support. I would be happy if I knew if RemoteDesktop makes a difference.

cesarm's profile image cesarm posted 3 months ago Permalink

I understand.

This way it affects my work a lot. And as I told you, I can't access it without using Remote Desktop for permission and access issues.

Could you insert an option to turn DPI support on/off?

ansgar's profile image ansgar posted 3 months ago Permalink

You can turn off high DPI support only by modifying your shortcut icon (from the taskbar):

Description

However, I need to fix that if I can, as I cannot tell the users they should turn off high DPI support.

ansgar's profile image ansgar posted 3 months ago Permalink

I just tested with RemoteDesktop from Win11 to a Win10 system with 225% DPI scaling. Still looks ok to me:

1 attachment(s):
  • dpi-win10-250percent-rdp
cesarm's profile image cesarm posted 3 months ago Permalink

To simulate, on my Remote Desktop, I open Heidi on my second screen.

Then I close Remote Desktop as is.

Then, I open the Remote Desktop again: Heidi automatically "returns" to the main screen, already unpositioned, according to the image posted earlier.

About disabling DPI Support on Windows, it didn't work. If I could disable this in Heidi (as it was in earlier versions of Heidi where DPI Support was not used) it would be ideal for me.

My suggestion is that DPI Support remains on in new versions, but that there is an option to disable it (for those who want to disable it).

What do you think about this?

ansgar's profile image ansgar posted 3 months ago Permalink

Would be nice if I could add such a preference option. But that's just not possible, because dpiAwareness is enabled via manifest XML file, which is baken into the executable file: https://docs.microsoft.com/en-us/windows/win32/hidpi/setting-the-default-dpi-awareness-for-a-process There is no way to disable or enable that in the app itself.

I just tested to override the DPI settings in the taskbar link properties, as I explained above, and see that it works here. Probably you did not select "System"?

Description

If that does not work for you, and you want to disable DPI awareness, you will have to use an older version of HeidiSQL, until I find a way to reproduce and to fix that issue.

cesarm's profile image cesarm posted 2 months ago Permalink

Hello my friend. Thank you for always answering me and trying to help me.

To solve my problem, I set the scale of both monitors to 100%.

HeidiSQL's responsive functionality doesn't work well when there are monitors with different scales. Example: monitor 1 with 150% scale and monitor 2 with 100% scale.

If this issue is resolved in the future, I would be very grateful if you could let me know.

Thank you and have a good week.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.