How to find the bigger packs? - SQL Error (1153): Got a packet bigger than 'max_allowed_packet' bytes

JAB Creations's profile image JAB Creations posted 3 weeks ago in General Permalink

SQL Error (1153): Got a packet bigger than 'max_allowed_packet' bytes

Instead of just blindly jacking up the limit how do I find this larger packet?

Notice: You can disable the "Stop on errors in batch mode" option to ignore such errors

I looked through HeidiSQL's preferences and can't find that option.

JAB Creations's profile image JAB Creations posted 3 weeks ago Permalink

I did resolve the error by clearing out a temporary database table so eh, not a huge ordeal though it would be nice to be able to know how to track down whatever the issue is instead of just jacking the setting for the entire server for a single bad query.

ansgar's profile image ansgar posted 3 weeks ago Permalink

First, this is the mentioned "Stop on errors" button:

Description

I know it's a bit hard to find, but it's anyway not a good idea to unpress/disable it.

What is meant by that max_allowed_packet is a server variable:

SELECT @@GLOBAL.max_allowed_packet, @@SESSION.max_allowed_packet;
@@GLOBAL.max_allowed_packet @@SESSION.max_allowed_packet
67108864 67108864

If you want to alter that value to a larger value, you need to set it in the server's my.ini file.

JAB Creations's profile image JAB Creations posted 2 weeks ago Permalink

Thanks Ansgar!

Please login to leave a reply, or register at first.