Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Cannot connect to another server on the network.

rzlines's profile image rzlines posted 10 years ago in Creating a connection Permalink
I have installed Heidi on 2 computers on an internal network. These computers also have XAMPP installed on both computers. I am able to successfully connect to the MySql databases hosted on the same computer.

When I try to connect to the MySQL databases which are hosted on the 2nd computer via IP, I get an error saying that I'm not allowed to connect to that database. When i connect to the same database on the other computer via PhpMyAdmin(i use the local IP to connect)it connects successfully. I have set all the firewall permissions to allow Heidi on the network.
ansgar's profile image ansgar posted 10 years ago Permalink
pma connects from localhost to localhost in your case. Your MySQL users are restricted to connect from localhost only. Just allow "%" as hostname for these user accounts and the other pc should be able to connect.
rzlines's profile image rzlines posted 10 years ago Permalink
How do allow % as a hostname? Is this a setting in heidi or apache.
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 10 years ago Permalink
In MySQL's user accounts. You can manage your users in Heidi via "Tools" > "User manager". Then, click on the user which cannot connect and set its host to "%".
rzlines's profile image rzlines posted 10 years ago Permalink
Thanks a lot that worked! happy
stu's profile image stu posted 8 years ago Permalink
I have the same issue between 2 pcs, windows vista containing a vm of debian running xampp. 2 different IPaddresses. Im trying to manage the mysql on linux from windows. (as well as PMA) I tried setting the 3 instances of root in users "host" to % and it didnt work.

Please login to leave a reply, or register at first.