Unable to connect via heidisql's SSH tunnel - and crash on editing a datetime field []

fusioned posted 7 years ago in General
I'm currently using version, and this seems to have a number of bugs that were not present in earlier versions (or were fixed).

1. I have a putty session setup which has the login name pre-setup, and an associated private key (though pageant handles these duties if omitted). This connects fine in putty and the subversion client (via plink).

In Heidisql's session manager, the ssh host is set to the name of the putty session - username, private key etc. The Settings tab has hostname = localhost, port=3306 etc. In some previous versions this has connected fine (FYI the server is on the intranet). Now, I receive the SQL Error (2003): Can't connect to MySQL server on 'localhost' (10061)

I have tried entering the connection details directly (not using session etc). In my firewall connections table, I can see plink setting up the connection to the server, so it looks like it is when Heidisql attempts to create the MySQL connection itself that is failing.

On the other hand, using a standard TCP/IP session (and opening a tunnel via a PuTTY terminal session instead of plink) - i.e. port=13306 - this works fine.

2. The app is crashing when attempting to edit a datetime field - first the madexcept window appears, but that is not accessible - the Windows crash prompt appears straight after, and the only option here is to close the program.

I am in the data tab of a table, and filtered some records. Within the filtered records, whether I press F2 on the field, or Enter, or double click, the crash occurs. Every other field seems to work fine.

The problem details from Windows - whilst I doubt it will be useful, I'll paste anyway as I cannot access Delphi's stack report:

Problem signature:
Problem Event Name: APPCRASH
Application Name: heidisql.exe
Application Version:
Application Timestamp: 4ce809d3
Fault Module Name: heidisql.exe
Fault Module Version:
Fault Module Timestamp: 4ce809d3
Exception Code: c0000005
Exception Offset: 0006b663
OS Version: 6.1.7600.
Locale ID: 2057
Additional Information 1: 19c6
Additional Information 2: 19c6d965cd2de7a1d4ffc18eeb9580c1
Additional Information 3: 94b0
Additional Information 4: 94b0916fbaccb07a9919f603d3592820

The exception given in the general tab of the madexcept dialog is: EStackOverflow
fusioned posted 7 years ago
Just to test, I have also tried updating to the latest version 3638 - no changes with the bugs.

However, the strangest thing happened. I downloaded r3570 to test with, and I managed to use the same session with the SSH tunnel successfully. Subsequent openings with r3638 is fine!

The datetime field bug still stands though.
fusioned posted 7 years ago
Just to confirm it is not my server, the r3603 on my laptop fails to connect to the same server via the heidisql SSH tunnel - identical settings to my desktop.
fusioned posted 7 years ago
Just some feedback on issues with connecting with Heidisql's SSH tunnel facility:

increasing the plink timeout to 8+ seconds has helped it to connect consistently.

However the issues with the date editing bug stands - and you'll have to suggest a way for me to capture any callstack data to pinpoint the bug!
ansgar posted 7 years ago
Obviously there is no way to get the callstack if the MadExcept window is just visible for 1 second. I can only recommend a general way to reset all your registry settings, of which there is probably one causing the crash (but probably not):
- exit all HeidiSQL instances
- run regedit.exe
- navigate to HKEY_CURRENT_USER\Software\HeidiSQL
- rename key "HeidiSQL" to "HeidiSQL_Backup"
- start HeidiSQL and see if the problem persists.
Be aware that your session settings are stored in this registry key.
samhill5215 posted 7 years ago
SSH tunneling has been a problem in the past for and I've posted on this in the past. Until recently the only way I had of connecting to a networked machine was via TCP/IP which of course is not secure and should be avoided. Happily I just figured out how to do it on a server I just set up that accepts only SSH connections from the outside.

Here are my parameters:
Network type: SSH tunnel
Hostname/IP: localhost ( will work as well)
User: <mysql user>
Password: <mysql password>
Port: 3306
SSH host: <server ip address>
SSH port: 22
Username: <server login>
Password: <server password>
Local port: 3307

The port settings are standard. One more thing was necessary before these parameters actually worked. Without that step the connection failed. What I had to do was run plink on a command window to create a connection key that plink stores and uses in future sessions.

Run plink without parameters for a printout of its options but here's what I ran:

plink -ssh <server login>@<server ip address>

plink will report that the connection is not secure and prompt for the creation of the key. Once that's done you'll be able to connect Heidi to the server via SHH.
ansgar posted 7 years ago
Thanks a lot for sharing!
Rapid-eraser posted 7 years ago
you can use putty for the initial keys accept. both programs use the same resources.

Please login to leave a reply, or register at first.