DelphiXE compile problem

igibum posted 7 years ago in General
Hi, i can't compile any of packages in source code with delphi xe. Is there fix for this?

Thanks in advance.
ansgar posted 7 years ago
What error messages to you get? Did you follow the few advices in the readme.html?
igibum posted 7 years ago
"E2011 Low bound exceeds high bound" i SynHighlighterJava.pas lines 876 and 981... when i try to compile SynEditR.bpl in delphi 2010, in delphi XE i first have incompatibile compiler error and after that, lots of "E2010 Incompatible types AnsiChar and Char" errors in SynUnicode.pas unit... I tried with source from download section because i don't have svn installed atm..

Thanks in advance for response
ansgar posted 7 years ago
You will need to get the latest source files via SVN.
igibum posted 6 years ago
i have installed last version over svn but still have "E2011 Low bound exceeds high bound" error in SyHighliterJava.pas...
problematic code is this two... when i reverse them i can compile code...

'Ŕ'..'Ö', 'Ř'..'ö'
ansgar posted 6 years ago
Looks like some encoding problem on your side. Did you touch that SynHighlighterJava.pas with some external editor and left it with a wrong file encoding?
igibum posted 6 years ago
No, it is original as downloaded... I tried on 2 computers, both on win7 pro. Delphi 2010 on one and delphi xe on other, and got same error on both...
Krienas posted 6 years ago
the same problem here
Krienas posted 6 years ago
Ah never mind. Took a look at repository and understood that characters I see are different from those visible there.

In repository I see: 'À'..'Ö', 'Ø'..'ö', 'ø'..'ÿ'
In my file I saw: 'Ą'..'Ö', 'Ų'..'ö', 'ų'..'˙'
igibum talks about: 'Ŕ'..'Ö', 'Ř'..'ö'

Apparently Delphi acts as it say in manuals, opens files in the same encoding as OS, so international characters can be converted. Fixing characters solves an issue.

By the way source in repository is different from version which we get by downloading source archive. Archive is for Delphi 2010. Repository version is already converted to XE. XE2 users still need to do some additional work to compile.
Ti9eR posted 6 years ago
How to compile in XE2?

Please login to leave a reply, or register at first.