distal-attribute
distal-attribute
distal-attribute
distal-attribute

Lost conection after Update

User, date Message
Written by jogowa
1 year ago
Category: General
5 posts since Wed, 22 May 13
I'm using now revision 4396 and now the old conection to my local database is corrupt.
I've got the Events:
/ * Connect to MySQL on localhost (TCP / IP), username root, password use: Yes ... * /
/ * SQL Error (2003) in statement # 0: Can not connect to MySQL server on 'localhost' (10061) * /
/ * Connect to MySQL on localhost (TCP / IP), username root, password use: Yes ... * /
/ * SQL Error (2003) in statement # 0: Can not connect to MySQL server on 'localhost' (10061) * /
/ * [Qnap-db] Connection to MySQL via qnap-drive (TCP / IP), username root, password use: Yes ... * /
/ * [Qnap-db] Connected. Process ID: 68039 * /

With the last used version 7 rev. 4388 it was working well.

Thr conections to extern Databases working well.
Thanks
Written by ansgar
1 year ago
4940 posts since Fri, 07 Apr 06
(Windows-) Firewall blocks it because you updated heidisql.exe?
Written by kmette
1 year ago
2 posts since Wed, 22 May 13
I'm on Win7 machine - 64 bit and I added HeidiSQL to the allowed programs in the firewall but still errored. Then I turned the firewall OFF and tried with no luck.

Still getting the SQL Error (2003) when accessing my local machine. Other MySQL servers are responding perfectly.

Thanks.

Kevin
Written by Misha v.3Money, Euro
1 year ago
13 posts since Wed, 07 Mar 07
I have the same issue. Win7 Pro 64bit, MySQL 5.5.28, connection to localhost using TCP/IP with pre-saved password.

For now I downgraded back to 7.0 and it works fine.
Written by ansgar
1 year ago
4940 posts since Fri, 07 Apr 06
Shit, if that's not a firewall issue, what could cause such a pure localhost problem then?
Written by Misha v.3Money, Euro
1 year ago
13 posts since Wed, 07 Mar 07
No ideas.
I install 8.0 over 7.0 once again and get the same issue again.
I tried to disable firewall -- the issue still here.
Then I replace "localhost" by 127.0.0.1 and it is connected to local MySQL server without any problems.
I hope it helps.
Written by jogowa
1 year ago
5 posts since Wed, 22 May 13
I've got the problem!
When I enter "localhost" in the field Hostname/IP the connection is not established.
With "127.0.0.1" it works. How ever.
Thanks for your help.
Written by ansgar
1 year ago
4940 posts since Fri, 07 Apr 06
Troubleshooting hints:
http://dev.mysql.com/doc/refman/5.0/en/can-not-connect-to-server.html
Written by Misha v.3Money, Euro
1 year ago
13 posts since Wed, 07 Mar 07
Thanks for the link.

- I can connect to local MySQL server using "localhost" server from HeidiSQL 7.0.
- I can connect to local MySQL server using "mysql -hlocalhost -uuser -ppassword" command.
- I can connect to local MySQL server using "telnet localhost 3306" command.

If you believe that this is not HeidiSQL 8.0 issue it is OK. Not a big deal to type in "127.0.0.1" instead of "localhost".
Written by ansgar
1 year ago
4940 posts since Fri, 07 Apr 06
I don't have that problem here, with the same HeidiSQL 8.0.0.4396 and "localhost".

One last question: Did you do a fresh install of HeidiSQL, or just an update? Please check and post the version of your installed libmysql.dll - you can see that in HeidiSQL's bottom status bar, when hovering with the mouse over the server version "MySQL x.x": "Client version: ???"
Written by jfalchMoney, Euro
1 year ago
382 posts since Sat, 17 Oct 09
this is most probably an ipv4/ipv6 issue. localhost on your machine is probably not bound to ipv4 127.0.0.1 (as it used to be), but to ipv6 ::1 - you can test this with a cmd window and the command ping localhost .

the mysql server listens for incoming requests on only one ip address, as specified by the bind param in its config file (my.cnf, my.ini). when this is 127.0.0.1, you can reach it via ipv4; i have not tried to use ::1 there.
this talks of using bind=0.0.0.0 - have not tried that either.
Written by jogowa
1 year ago
5 posts since Wed, 22 May 13
I'm using the updates.
MySQL Server ist 5.5.27
Conectors:
ODBC 5.1.6
C++ 1.1.0
C 6.0.2
J 5.1.20.0
Net 6.5.4
I've to use this ODBC Connector because the new one dos'nt work with MSO Access 2010.
Written by jogowa
1 year ago
5 posts since Wed, 22 May 13
@jfalch ping is givig a response from ::1:
So the Hosts file must have a change?
Written by kmette
1 year ago
2 posts since Wed, 22 May 13
I did an uninstall of v7 and install of v8.

MySQL 5.1.61
libmysql 6.0.0

Using 127.0.0.1 does work.
Written by ansgar
1 year ago
4940 posts since Fri, 07 Apr 06
Could be the libmysql.dll bundled with HeidiSQL 7 did its own resolution of "localhost" to "127.0.0.1", while the newer libmysql from HeidiSQL 8 does not do that any longer. Now, your server may be bound to 127.0.0.1, or your hosts file has bound it to ::1, and there you got the problem.
Written by Misha v.3Money, Euro
1 year ago
13 posts since Wed, 07 Mar 07
I've installed version 8.0 over version 7.0
client libmysql version 6.0.0
ping localhost also response ::1:
There is no bind option in my.ini file.
There is no localhost binding in hosts file.
I overwrited libmysql.dll by the version from HeidiSQL 7.0 and localhost resolved correctly.
Written by Misha v.3Money, Euro
1 year ago
13 posts since Wed, 07 Mar 07
I've added line

bind-address=::


into mysqld section of my.ini and now HeidiSQL 8.0 can connect to local mysql server using libmysql 6.0 with "localhost".
Written by jogowa
1 year ago
5 posts since Wed, 22 May 13
Thats it.

bind-address=::


Thanks for your posts.
Written by Eddy-B
11 months ago
1 posts since Sat, 31 Aug 13
This issue is 3 months old... why is the solution not yet included in build 4499 ?
Written by jfalchMoney, Euro
11 months ago
382 posts since Sat, 17 Oct 09
because there is no solution to include. the problem depends on the changed behaviour of libmysql.dll, which is an external component, not under control of the heidisql developer. the only solution possible when using the newest version of libmysql.dll (which is advisable) is the one mentioned above, ie to modify the server configuration when using ipv6. for a client, it should also possibly work to download an earlier mysql distriution, extract libmysql.dll from that, and use it.
 

Please login to leave a reply, or register at first.