distal-attribute
distal-attribute
distal-attribute
distal-attribute

Stop on errors button not working?

User, date Message
Written by yashirotcm
1 year ago
Category: General
4 posts since Sat, 17 Aug 13
So I'm trying to import this sql file which I must say is kinda big but it appears to have a duplicate entry in it and the procedure just stops forcing me to start all over again, I was suggested to "unpress" the "Stop on errors in batch mode" button but pressed or unpressed it does not make a difference, is there anything I'm doing wrong or is that button broken in this build? thanks.

Version: 8.0.0.4396
Written by ansgar
1 year ago
5045 posts since Fri, 07 Apr 06
Do you run that sql file with the "Run SQL file" dialog or do you load it into the editor? The "Stop on errors" button is just for the editor, but it sounds like a good idea to make it work also for the run dialog.
Written by yashirotcm
1 year ago
4 posts since Sat, 17 Aug 13
I do Use the "Run SQL File" option, should I load it the editor first?
Written by ansgar
1 year ago
5045 posts since Fri, 07 Apr 06
As said, the "Stop on errors" button is just for the editor, but I should probably turn it to work also for the run file dialog.
Written by ansgar
1 year ago
5045 posts since Fri, 07 Apr 06
Oh I just see that I recently turned the loop-breaking error dialog into a simple popup which does not stop the whole sql import. Please just update your HeidiSQL to the latest build and try again.
Written by yashirotcm
1 year ago
4 posts since Sat, 17 Aug 13
Just tried again with the latest version, problem still there:

Written by ansgar
1 year ago
5045 posts since Fri, 07 Apr 06
r4396 is not the latest build, but the latest release. Please update to the latest build. (Help > Check for updates)
Written by yashirotcm
1 year ago
4 posts since Sat, 17 Aug 13
After updating I can now confirm that the problem is fixed, thanks :D
 

Please login to leave a reply, or register at first.