distal-attribute
distal-attribute
distal-attribute
distal-attribute

heidi 8.2 mssql ubuntu 13.04, no MDAC

User, date Message
Written by linusklan
9 months ago
Category: General
3 posts since Fri, 20 Dec 13
Hi.

In new version HeidiSql (8.2) and J can't open any TCPIP mssql db

J have message:
"Error creating object. Please verify that the Microsoft Data Access Components 2.1 (or later) have been properly installed Sprobuj zainstalowae MDAC w Wine: > wget http://winetricks.org/winetricks "

But Heidi 8.1 works perfect.
Written by ansgar
9 months ago
5018 posts since Fri, 07 Apr 06
The connection layer has not been touched between 8.1 and 8.2. But probably you are now using the 64bit version of HeidiSQL, and MDAC perhaps requires a 32bit version? Please check.
Written by ansgar
9 months ago
5018 posts since Fri, 07 Apr 06
linusklan, please report back if it turned out to be a 64bit issue.
Written by linusklan
9 months ago
3 posts since Fri, 20 Dec 13
Hi ansgar,

Thanks for you reply, you're right it is problem wihth 32 and 64 bit version. 32 bit version HeidiSql works perfect.

But J was installed Heidi from instaler, and His install for me
64 bit version :(.



Written by ansgar
9 months ago
5018 posts since Fri, 07 Apr 06
Is there a way to emulate Win32 in Wine?
Written by linusklan
9 months ago
3 posts since Fri, 20 Dec 13
J think wine developers prefer win32 emulation, because it is emulation, we don't have win64 speed advantage. Now I have 64 bit machine but under wine J install 32 bit applications.
Written by ansgar
9 months ago
5018 posts since Fri, 07 Apr 06
The installer detects a 32/64bit Windows automatically, and it has both versions of heidisql.exe. The installer is created with a InnoSetup script. Likely it detects a 64bit system in your Wine.

I guess you need a pure 32bit installer for getting MDAC to work, right?
Written by TTSneko
9 months ago
41 posts since Thu, 19 Jul 12
MDAC 64bit is not available as standalone redistribution package; the freely available MDAC is 32bit only. Hence WINE users are forced to install Heidi as 32bit application, yes.
 

Please login to leave a reply, or register at first.