distal-attribute
distal-attribute
distal-attribute
distal-attribute

Can't create TCP/IP socket (10093)

LuckyLuke posted 12 months ago in Creating a connection
Good day!

I can not connect to remote MySQL database through HeidiSQL.

I get message "SQL Error (2004) in statement #0: Can't create TCP/IP socket (10093)"

I run Heidi 8.3.0.4694 on Slackware 14.1 through wine 1.7.15.

I can connect to my MySQL server from command prompt, both as root and as user.

mysql -h xxx.xxx.xxx.xxx -P xxxx -u xxxx -p

So problem is not firewall issue. My guess is that problem is somewhere between wine and Heidi.

Can anybody help with this issue?

I do not remember any problems at all on Slackware 13.37, wine 1.5.31, Heidi 8.0.

Thank you in advance!
LuckyLuke posted 12 months ago
BUMP!

Can anybody give an idea where to look at?

UPDATE -
I have tested SQLyog which also runs under wine. No problems, I can connect to my remote MySQL server as root and as normal user.


When I run HeidiSQL from root desktop environment, I can estabilish connection.


However for root are some other issues. Some buttons are not visible, fonts are weird, and database window is opened behind login window. I have to close manualy login window, to see successfuly opened database.

Anyway, I do not want to use Heidi from root environment.

Why I can not create TCP/IP socket as normal user?

Could it be some permissions issue? Where exactly TCP/IP sockets are located under wine? I could check permissions for that location.

Can I see somewhere stack trace for Heidi error "SQL Error (2004) in statement #0: Can't create TCP/IP socket (10093)"?

Thank you in advance!
ansgar posted 12 months ago
I have no clue, sorry.

This one says it's a Windows issue, but you're using Wine:
http://www.qtforum.org/article/14177/can-t-create-tcp-ip-socket-10093-qmysql-unable-to-connect.html?

Also: http://grokbase.com/t/mysql/odbc/026ac5k9k4/tcx-myodbc-cant-create-tcp-ip-socket-10093
jfalch posted 12 months ago
http://msdn.microsoft.com/de-de/library/windows/desktop/ms740668%28v=vs.85%29.aspx says "either didnĀ“t call WSAStartup (unlikely), or WSACleanup already called (possible program logic error?)...

Please login to leave a reply, or register at first.