distal-attribute
distal-attribute
distal-attribute
distal-attribute

row field very large

User, date Message
Written by acemtp
7 years ago
Category: General
3 posts since Thu, 19 Jul 07
I used heidisql for a few month without any problem.

But now, varchar fields are very large (more than 800 pixels large) when if I resize manually when do a refresh (F5), or restart heidisql, fields resize to the large value...

I tried to resintall the latest version, same thing.
Written by ansgar
7 years ago
4988 posts since Fri, 07 Apr 06
Just set the following option:
Tools > Preferences > Data-Appearance > "Maximum column width ..."
Written by acemtp
7 years ago
3 posts since Thu, 19 Jul 07
Ok, thank for the workaround
Written by ansgar
7 years ago
4988 posts since Fri, 07 Apr 06
ehm, that is not a workaround, it was supposed to be a feature, guy :)
Written by acemtp
7 years ago
3 posts since Thu, 19 Jul 07
OkaysmileBut the value is 0 (automatic) and I never change this value, so do you have an idea of why it was ok before without changing this value?

Anyway, the main thing is that's work :)

Thank you
Written by ansgar
7 years ago
4988 posts since Fri, 07 Apr 06
I think 0 is the default value which applies on a first time installation.
Written by Saturday3AM
7 years ago
6 posts since Thu, 26 Apr 07
Thank you very much for this, I had this same problem appear suddenly for no apparent reason.

Written by mike.tomsk
7 years ago
1 posts since Sun, 24 Feb 08
Yes, this annoying me too. I have 0 (automatic width) in this parameter, but some fields became very long, and even if field is not very long, it still much longer than length of data. Is it bug or feature, and how can this be fixed?
Written by ansgar
7 years ago
4988 posts since Fri, 07 Apr 06
Would it be an option for you to set the preference value to let's say 120 or so (before we call it a bug:))?
Written by doxon
6 years ago
1 posts since Tue, 11 Mar 08
Hi anse,

I have the same problem.
If I change the value to 0, many columns are displayed very long. Also if the cells are empty in all rows.

If I change it to eg. 120 the "empty" columns are also Displayed so long.


I hope you unterstand my problem ;)

Isn't there any possibility to size the columns depanding on the data?
long data -> big field, no/short data -> small field.
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08
Hi guys,

I have been using HeidiSQL for about 3-4 months now and find it very easy to use. Great tool to have around.

One problem I have come across is the same as the users who have posted before me.

Was curious is it possible to have a setting which will either adapt to the field name size or/and field text, the lower of the two will be selected as the width?

This way if there is no data in the field it will just display the width of the field, and if there is data you will need to either hover over it to see the full size of the data.

Thanks.
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
Good idea, really, very creative. However, that would slow down the process of displaying data significantly as we will have to check the length of *each* cell in *each* row while creating the columns. Even cells which are not yet fetched must be checked which is not possible I'd say as we're fetching chunks of data on demand as you scroll down a huge table.

Did you know
- the columns keep their resized state when refreshing data and
- that they now support autosizing on doubleclicking the border between two columns
in the latest builds? That's not exactly what you meant but probably it helps a bit.
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
I think what is most annoying here is that numeric columns take too much space. VirtualTree has an easy way to implement an autosized column depending on its datatype, how's that idea?
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08

anse wrote: I think what is most annoying here is that numeric columns take too much space. VirtualTree has an easy way to implement an autosized column depending on its datatype, how's that idea?



How about loading the table data, and then autosizing the columns then? Looking at whats smaller perhaps (?) or maybe just making it the width of the field names?
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06

serbianking wrote: How about loading the table data, and then autosizing the columns then?



That implies that the complete data gets loaded at the beginning, which wouldn't be a good idea for my 55 gb laws tablesmileOr did you mean that we only use the visible fields for autosizing? Would be odd I think.
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08

anse wrote:

serbianking wrote: How about loading the table data, and then autosizing the columns then?



That implies that the complete data gets loaded at the beginning, which wouldn't be a good idea for my 55 gb laws tablesmileOr did you mean that we only use the visible fields for autosizing? Would be odd I think.



Well I guess that could be a problem. How about just making an option where the field names will determine the default width of the columns? This would be less problematic?
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
Related change: http://changes.heidisql.com/1712
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08

anse wrote: Related change: http://changes.heidisql.com/1712[/quote:a2a657e88c]

What does the value have to be set to for it to automatically do this? I can't seem to set it to 0?

Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
Misunderstanding, sorry: r1712 didn't fullfill this request, it was just a related change, possibly of interest here.

I wouldn't say we should do this resizing automatically when the preference value of "Maximum column width..." is set to "0" or?
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08

anse wrote: Misunderstanding, sorry: r1712 didn't fullfill this request, it was just a related change, possibly of interest here.

I wouldn't say we should do this resizing automatically when the preference value of "Maximum column width..." is set to "0" or?



Well if "0" sets the default which is a reasonable size then I guess no need for it.

Can the column header sizes be saved, that way once you create a new table you can fix the widths of each column yourself and they will be saved? Maybe even have an option under "Columns" with "Save header size"? Or per column widths?
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
Thanks a lot for the idea. Posted as rfe 732
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08
Not a problem. :)
Written by ansgar
6 years ago
4988 posts since Fri, 07 Apr 06
Try it out - nightly build of r1776 and following fixes should avoid some annoyance from now on.
Written by serbianking
6 years ago
8 posts since Thu, 14 Aug 08

anse wrote: Try it out - nightly build of r1776 and following fixes should avoid some annoyance from now on.



seems to work for now ;)
 

Please login to leave a reply, or register at first.