distal-attribute
distal-attribute
distal-attribute
distal-attribute

How to put limit less than 5000 lines?

Valery posted 6 years ago in General
For me comfortably to put limit 0,50 to view (use large tables on a remote machine).
How to save these settings?

Thank!

Sorry for my bad English :)
ansgar posted 6 years ago
You can manually specify a lower limit of let's say 10 rows in the LIMIT options at the very top. But that value gets discarded when you switch to another table with more than ~5 MB data. The data grid automatically calculates a limit which ensures you never get more than the above mentioned 5MB over the net. Should be ok for most situations I think.
Valery posted 6 years ago
Please, if it is possible, return save Limit settings ...

For idea - three states of checkbox:

1. no LIMIT (uncheck)
2. autoLimit (gray check) (auto limit from settings: 0.1, 0.2, 0.5, 1, 2, 5 M)
3. user settings (checked) (from inputs)

State checkbox save in reg...

Always "Auto" - not very much comfortably :(

Thank!
ansgar posted 6 years ago

wrote: Always "Auto" - not very much comfortably


What exactly is uncomfortable here? The auto limit does a good job I think, always being some emergency limiter on tables larger than 5M.

Recently there was quite some confusion about this auto limit feature and a related checkbox in the preferences window, and I'm glad we found a usable way now without loosing important functionalities. I'd hate bringing back this confusion and surely many users too.
Valery posted 6 years ago
It is sorry that the simplest tuning causes such ununderstandings.
A correct "automat" in the similar systems always has ben the hand tuning.
5м - it very much :(

Sorry to an anxiety.
I will use an old beta.
I am not have a T1 - channel :cry:
ansgar posted 6 years ago
Well, you can use an older build but be aware you'll run into other bugs which have significantly greater impact and bad side effects.

You can manually set a lower limit, even before you click the data tab (the limit controls are visible as soon the table tab is active). So where exactly is the issue now?
Valery posted 6 years ago
In switch on other connect or open/close programm my choice is not
memorizedunhappy
In a version 1296 Checkbox always member my choice: LIMIT 0,50

Now mode always set in "auto" on new connection or open/close programm ... :(
ansgar posted 6 years ago
Ah.. coming closer to the point now. I guess this is easy to fix, we can just save the value of the limit boxes in registry while the window is closing, together with all the other registry spam.

That would make it slighly more comfortably for all sessions.

Please post that to our feature tracker so it gets into our normal workflow.
Valery posted 6 years ago
Posted Issue 619

Thanks!!! :D
macseamus posted 6 years ago

anse wrote: Should be ok for most situations I think.



I agree with the other poster, i can't see why you think it's a good idea to impose this amount of data transfer, with NO WAY to avoid it. I have to wait about five minutes for the table to load. so i use an old copy of mysqlfront, set the limit to 5, load the data, sort by date, get to the last record which is where i want to go, make the edit, and heidisql is still loading 5000 lines.

And, I have just download the latest release 3.2 and i do not see the LIMIT controls until i activate the data tab, and then i have to wait 5mins + to get control back. try it yourself on a slow link. they still exist you know.

I usually post thanks and gratitude, but it this case, i'm sorry but your attitude sucks, and your otherwise terrific program becomes unusable, and i have no option but to use mysqlfront.
ansgar posted 6 years ago
a) Please keep in mind that you're talking about a nightly build, or call it beta. If you need a stable version, use the 3.2 final.
b) What about being a bit more creative and make suggestions how to enhance these things?
macseamus posted 6 years ago

anse wrote:
What about being a bit more creative and make suggestions how to enhance these things?



Hi anse, OK, look sorry about my attitude in the last frustrated post. You are right, I should be more helpful, so here is my suggestion to make this program better:

anse wrote:

You can manually specify a lower limit of let's say 10 rows in the LIMIT options at the very top. But that value gets discarded when you switch to another table with more than ~5 MB data.



1. Remove or make optional this limit discarding functionality. Also, make it possibly to set the limit BEFORE the HeidiSQL sends "SELECT * from table_name"

In case there is some doubt, please let me describe my experience with the program, and note, I may have jumped in here in the wrong place, but I am not talking about betas or nightlys, but the latest stable release.

I open the program and connect to the remote database, I select the table in the left column, and the Table tab is activated, at this point there is no LIMIT box visible, then I click on the Data tab and SQL LOG shows
SELECT * FROM `table_name` ORDER BY `id` DESC LIMIT 0, 1000

I wait 6 minutes and 11 seconds for SQL to retrieve 1,000 records (about 3.2M in this case, of a total of 45,000 records from a remote server over a ssh tunnel link, so yes, this is a lot slower than the theoretical speed of my current connection, a 3M/512 ADSL, without the overhead I should get that data in about 20 seconds.

I change the LIMIT to 5 and click OK. I get 5 records. I change to another table by clicking in the left hand column. I change back to the original table, and heidiSQL issues SELECT * FROM `table_name` ORDER BY `id` DESC LIMIT 0, 1000 again. I have no choice at this point but to wait another 6 or 7 minutes, or force close the TCP connection and close the program.


anse wrote:
Recently there was quite some confusion about this auto limit feature and a related checkbox in the preferences window,



oh dear, :oops: i have only just found this, I guess that solves the problem, in that I can set a default limit based on my connection speed and never have to wait so long again. I understand now that the emergency limiting is exactly that, it was not conceived to be the default limit, my apologies.

However, setting this means that if I change the limit while viewing data, then change the table, and change back again, the LIMIT changes back to whatever I have specified in the preferences as default. I do not think it necesary to save LIMITs for each table in the registry, although I can see how people might like this feature, however, it would be pretty cool if the limit could stay at what it is set as for the session, per table would be great, but even just staying at what I put in the limit box would be good.

Thanks anse, and apologies again for posting in a tired grumpy mood. I should know better at this stage!!

Please login to leave a reply, or register at first.