distal-attribute
distal-attribute
distal-attribute
distal-attribute

How to turn off Popup Editor

User, date Message
Written by aewhite903
6 years ago
Category: General
5 posts since Mon, 24 Sep 07
Hi,
The popup editor is stopping me from pasting into a text field!
How do I turn the silly thing off and go back to the in place editor?
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06
There is currently no way to turn off this editor. Probably that will be an option in the future.

However, how does it stop you from pasting? It should behave exactly like the inplace editor?
Written by aewhite903
6 years ago
5 posts since Mon, 24 Sep 07
Hello,
Try copying some text to the clipboard now highlight a text field to change
then press Ctrl+V. Nothing happens. You actually have to double click the
field to get the popup editor then paste then click a button to close the
window. Way too complicated for quick working.
In my other program (sorry, had to go back to SQLFront) I simply highlight
field then paste and it is done, arrow key to next field and insert agian . For
LONG text in MEMO field it still works.
Hope you can fix this soon as it is very cumbersome and I hate using the
mouse where I do not need to.
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06
Well, no need to "fix" that if you're already using another toy, or?
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06
Btw, Ctrl+C and Ctrl+V already work as expected. There's only a minor timing problem with that it seems, you have to press the keys a tick longer than normally (let's say, half a second), then both shortcuts work as described.
Written by aewhite903
6 years ago
5 posts since Mon, 24 Sep 07
Hmm...
1. Not quite the answer I expected about using other Toy!
However, if that is your response then so be it I will switch
permanently back to MySQLFront if you so desire. NB I purchased
MySQLFront a very long time ago and keep it updated as I do
your product. They both have their strengths.
2. I did not say Ctrl+C and Ctrl+V were not working I said that HeidiSQL
was not responding to them. "Big" difference.
3. You are correct you must hold the keys for "27ms" longer than normal.
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06

aewhite903 wrote: Not quite the answer I expected about using other Toy!



Well your question did sound a bit pissed so don't expect a super friendly answer :)

aewhite903 wrote: I did not say Ctrl+C and Ctrl+V were not working I said that HeidiSQL was not responding to them. "Big" difference.



Sorry, I can't see any difference?
Written by aewhite903
6 years ago
5 posts since Mon, 24 Sep 07
Never mind !!!
Written by muzza4
6 years ago
51 posts since Mon, 04 Dec 06
Hi Anse,

I've been trying to use the latest builds instead of v3.2, and I've run into the same problems aewhite documented above.

Using v3.2 and inserting a new row into a table with 3 numeric and 2 text fields, these are the steps I take
1. position to last row
2. arrow down
3. type value
4. tab right
5. type value
6. tab right
7. type value
8. tab right
9. type value
10. tab right
11. type value
12. tab up

Using the build 1906 to achieve the same result
1. position to last row
2. arrow down
3. f2
4. type value
5. enter
6. tab right
7. f2
8. type value
9. enter
10. tab right
11. f2
12. type value
13. enter
14. tab right
15. f2
16. type value (in pop up box)
17. escape
18. enter (these last 2 steps equivalent to mouse click on apply changes)
19. tab right
20. f2
21. type value (in pop up box)
22. escape
23. enter
24. tab up

It’s all a bit laboured in my view, and I suspect you might lose a few customers when you put this code into the recommended release. Is there a possibility of having an option to select the insert style?

Regards
Muzza
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06
You can turn off all kinds of popup editors in the preferences dialog. If you do so your grid has inline editing again for the relevant column types.
Written by muzza4
6 years ago
51 posts since Mon, 04 Dec 06
Hi Anse,

So it does - thanks.

The only difference when inserting rows then, when comparing v3.2 against the daily builds, is the need to press F2 on every field.

Is this potentially a perference setting?

Thanks
Muzza
Written by ansgar
6 years ago
4963 posts since Fri, 07 Apr 06
No, not a preference setting. However, Enter is a second shortcut and probably more handy.

Feel free to post code ideas for that. I heard that before from a couple of people who want immidiate editing as soon as they click a cell.
 

Please login to leave a reply, or register at first.