distal-attribute
distal-attribute
distal-attribute
distal-attribute

Can't connect using ssh tunnel

User, date Message
Written by TaherS
3 years ago
Category: Creating a connection
2 posts since Mon, 11 Jul 11
Hello people

I see quite a few people having similar problems as I have but I haven't been able to find a solution that works for me =/

I'm trying to use Heidisql on my local windows 7 machine to connect to my MySQL-server installation on a VPS with ubuntu 10.04 as OS.

Under settings I chosen:
Network type: SSH Tunnel
Hostname/IP [VPS hostname]
user: [mysql user]
password: [mysql password]
port: 3306

Under SSH tunnel I have:
plink.exe: [path to plink.exe]
SSH host: + port [vps hostname] [22]
username: [shell user]
password [shell password]
Privae key: [blank]
Local port: 3307

With these settings I get the error "SQL Error (2013): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

When I change Local port to 3306 I get the error "SQL Error (2003): Can't connect to MySQL server on 'localhost' (10061)

I have verified that I can log into MySQL through phpMyAdmin and I have logged in with ssh (using Bitvise Tunnelier). While connected through ssh I started a MySQL session successfully querying my databases.



Written by TaherS
3 years ago
2 posts since Mon, 11 Jul 11
And while gathering all the different error messages I hade recieved I managed to log in!

The settings I had when I successfully logged in was:

Under settings I chosen:
Network type: SSH Tunnel
Hostname/IP: 127.0.0.1 <------
user: [mysql user]
password: [mysql password]
port: 3306

Under SSH tunnel I have:
plink.exe: [path to plink.exe]
SSH host: + port [vps hostname] [22]
username: [shell user]
password [shell password]
Privae key: [blank]
Local port: 3306 <-----

The two rows marked with arrows are the only things I changed..
Written by Rapid-eraser
3 years ago
34 posts since Wed, 23 Jun 10
Open putty and accept the certificate of the server
hostname should be localhost ( in order to use local socket and not http conection)

local port should be something like 33010 not 3306
local port is the conection back port used by the plink and has nothing to do with mysql ports

also see my older post :)
http://www.heidisql.com/forum.php?t=6765
 

Please login to leave a reply, or register at first.