Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

timeout error

[expired user]'s profile image [expired user] posted 9 years ago in Running SQL scripts Permalink
I always got this error:
SQL Error (0): Query timeout expired.

The client is connected to SQL server. The timeout in SQL server is enough.

How can I fix it?
ansgar's profile image ansgar posted 8 years ago Permalink
Just update to the latest build, and you will get a new "Query timeout" setting in the session manager's "Advanced" tab:
1 attachment(s):
  • sqlserver-querytimeout
mark_b's profile image mark_b posted 1 month ago Permalink

I know this is a super old thread but it seems the one that is best for me to ask via for others to find the answer.

Can I set the timeout via the command line ?

It look like I cant from the help - if not any chance of adding this as a command line parameter ?

mark_b's profile image mark_b posted 4 weeks ago Permalink

I have worked out a way around this - I use the portable mode for HeidiSQL so I edit the portable_settings.txt and save this with the correct host to connect to as part of the config of a session and then launch HeidiSQL with the parameter --description=<SESSION NAME>. I just edit the same session each time so I only need 1 session with the longer timeout. Bit of a hack but it works :-)

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.