Needing to connect to older MySQL server running Duo 2FA and using PLink SSH Tunneling.

DesignerAL's profile image DesignerAL posted 4 weeks ago in Creating a connection Permalink

When I try to log in, with PuTTY already logged in and telling it to use the plink.exe associated with my PuTTY app, it tries, understands my credentials for the tunneling, but then Duo tries to do its command line prompt asking me how I want my passcode.

In other apps like WinSCP, it gives me the GUI options to choose and then enter the passcode. In HeidiSQL it just informs me in a dialog popup that Duo needs me to make a choice, then it errors and fails to connect.

I did some Googling and asked one of our IT guys, and the general impression is that, if PuTTy is connected and HeidiSQL is using plink from PuTTy, it should just connect and that this doesn't make sense.

I have to admit I'm a bit lost.

ansgar's profile image ansgar posted 4 weeks ago Permalink

Ok, I'll try to help you out.

First important questions:

  • which HeidiSQL version are you using? If it's not the latest, please update HeidiSQL to v12.6 (latest release). Otherwise we are probably talking about old issues I already solved.
  • in your session settings, on the "SSH tunnel" tab, which executable is selected? Only plink.exe and ssh.exe are officially supported here.
DesignerAL's profile image DesignerAL posted 4 weeks ago Permalink

Greetings...and thanks! I am using 12.6.9.6765 currently.

The executable selected is plink.exe. In older versions I had to put the path to the plink in my PuTTy folder, but this one just has plinke.exe and ssh.exe to choose from, assuming the ones that come with Heidi?

DesignerAL's profile image DesignerAL posted 4 weeks ago Permalink

Sorry, 12.6.0.6765.

ansgar's profile image ansgar posted 4 weeks ago Permalink

Ok, then you could try out ssh.exe instead. But only if you connect per public key, without a password, as the Windows OpenSSH client cannot handle a password on the command line.

If that does not work for you, please post a screenshot of the "passcode" dialog you get with plink. There may be an issue with my plink pipes and I could probably solve that in a new build.

DesignerAL's profile image DesignerAL posted 4 weeks ago Permalink

Thanks for the prompt responses and your assistance so far.

I was able to get it connected by adjusting the tunneling settings in PuTTY to map the port to my localhost, then I just connected through HeidiSQL using the local as the domain, and just not using the SSH tunnel tab anymore.

Please login to leave a reply, or register at first.