Error message when trying to connect with SSH

sacapuce's profile image sacapuce posted 2 weeks ago in Creating a connection Permalink

Hi, I set up a connection to a MySQL database on a server with a SSH tunnel and I am getting the following error. The strange thing is that this connection worked six months ago and work when using the MySQL Workbench so I am not sure what is going on. I tried changing settings etc and it does not work. The file is there so not sure what is going on. Many thanks for your help Marc

Description

ansgar's profile image ansgar posted 2 weeks ago Permalink

You need the OpenSSH Client feature to use "ssh.exe". My guess is you were using putty.exe before (which you still can select on the SSH tunnel tab). However, to install the OpenSSH Client, go to Settings > System > Optional features, and click on the "Show features" button. Here's a screen from my Windows 11:

Description

On Windows 10 the way might differ.

sacapuce's profile image sacapuce posted 2 weeks ago Permalink

Hi, many thanks for your reply. I checked and the OpenSSH client seems to be installed. I am pretty sure I used SSH.exe before. Description

ansgar's profile image ansgar posted 2 weeks ago Permalink

Ok, then what happens if you run "ssh.exe" in a command prompt / shell window?

sacapuce's profile image sacapuce posted 2 weeks ago Permalink

I get that Description

sacapuce's profile image sacapuce posted 2 weeks ago Permalink

I did some research and tried to open the tunnel from command line using:

ssh -N -L 3336:localhost:3306 therrc@therrc.co.uk -i "C:\Users\mnaura\desktop\private-npp-openssh.ppk"

I got an error message: Corrupted MAC on input. ssh_dispatch_run_fatal: Connection to 5.134.13.241 port 22: message authentication code incorrect

Could it be a problem with mac algorithm?

ansgar's profile image ansgar posted 2 weeks ago Permalink

Uh that sounds like a server side issue. Are you still able to connect per putty or plink probably? You can select plink in HeidiSQL's tunnel settings.

Please login to leave a reply, or register at first.