Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Stream reas error

giordano2's profile image giordano2 posted 8 years ago in Running SQL scripts Permalink
I have one sql-script (1025 rows) which I can't load into HeidiSQL. When I want to load it with Datei/SQL-Datei laden or Ctrl-o I got the following message:
"Stream read error"
All other sql-files can be loaded. The work around is coping/pasting the code into HeidiSQL. Somebody has an idea what the error meansand how I can avoid it?
jfalch's profile image jfalch posted 8 years ago Permalink
hm. looks like some low-level disk error; i suggest you run checkdisk and see if the error condition goes away.
giordano2's profile image giordano2 posted 8 years ago Permalink
I did checkdisk but problem remains.
giordano2's profile image giordano2 posted 8 years ago Permalink
At the end I found this solution: Copy sql into notepad, saved it and renamed it with extension .sql. Now it works.
giordano2's profile image giordano2 posted 6 years ago Permalink

It happens again and now I found another solution to solve this problem: The sql file was utf8. I converted it to ANSI and back again to ut8 with Notepad++. I think there origin of the problem has to do with encoding. My working editor is Emacs.

Suranga's profile image Suranga posted 6 years ago Permalink

File -> Load SQL File . After locating the .sql file, select the Encoding Method as ASCII. It will solve the problem.

giordano2's profile image giordano2 posted 6 years ago Permalink

@Suranga. Thanks. I will try at the next opportunity. I didn't yet find out when this happens and when not.

lexxi2000's profile image lexxi2000 posted 4 years ago Permalink

Thy for the info with the encoding it worked!!

bratlucifer's profile image bratlucifer posted 4 years ago Permalink

This will be providing the part fo it.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.