Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

connection impossible (Connection using old (pre-4.1.1) authentication protocol)

richard's profile image richard posted 5 years ago in Creating a connection Permalink
Hi,
since HeidiSQL 9.0 i can't connect to our Server.

Error Message:
Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)

How can i disable 'secure_auth' in HeidiSQL ?

Richard Stracke
Buzz's profile image Buzz posted 5 years ago Permalink
Exactly the same error here, updated to v9 and now I can't connect to any of my DBs.

Please can you fix this or at least let me know how to disable the setting as per Richard's request above.

Thanks...Buzz

Buzz's profile image Buzz posted 5 years ago Permalink
Just seen the release thread, I'll give the older version of libmysql a go.
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
Buzz's profile image Buzz posted 5 years ago Permalink
Confirmed working with the older 64 bit version of libmysql
ansgar's profile image ansgar posted 5 years ago Permalink
See the v9.0 release thread. I will try to activate that secure_auth option, perhaps with a new checkbox in the "Advanced" tab of the session manager.

Please login to leave a reply, or register at first.