Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

[BUG] Selecting multiple databases in a session errors out in SQLServer

yan's profile image yan posted 4 years ago in Creating a connection Permalink
Using 92.2 4958 build
SQL Server 2014
US regional settings

When I select multiple Databases in the drop down in session manager, I get an "SQL Error (0): Invalid connection string attribute" when trying to connect. No issue if only one Database is selected.
Note that the string in Databases screen field shows as semi-comma delimited - wonder if 9.2 was not hardcoded to parse based on comma (Europe). However, weird is 9.1 worked fine.

Regards, Yannick
ansgar's profile image ansgar posted 4 years ago Permalink
That's because v9.2 supports MS Azure hosts, where you need to pass a database in the connection string ("Database=xyz"). HeidiSQL uses the database(s) setting for that purpose. This is wrong - I think I should not do that if it's more than one database in the list.
ansgar's profile image ansgar posted 4 years ago Permalink
Done in r4959. Works fine here. Please update HeidiSQL and see if that works for you.
yan's profile image yan posted 4 years ago Permalink
Forgot to answer - works back fine. Thanks Ansgar.

Please login to leave a reply, or register at first.