Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Export grid rows to delimited text doesn't respect number format

Dan Ko's profile image Dan Ko posted 2 years ago in Import/Export Permalink

Export grid rows feature is great and customizeable, but I've run into a little problem I can't fix with settings.

By default, I get period as the decimal part separator, but I need it to be comma. I've enabled the "Local number format" checkbox in settings and it worked for query results in the HeidiSQL interface and in export grid rows to "Excel CSV", but when I export grid rows to "Delimited text" I still get period as a decimal part separator.

Tried HeidiSQL 9.3 stable and 9.4 build 5174. I am on Windows 10, the DB is PostgreSQL and the field type is Numeric if any of that matters :)

ansgar's profile image ansgar posted 2 years ago Permalink

Well, delimited text should be most compatible to everything, so the period is used there, not the local character.

But you could make an extra-turn via Excel, then export it from Excel with your preferred settings. That should work, or?

baraniello's profile image baraniello posted 2 weeks ago Permalink

Up the problem! I tried the same thing (export double values to CSV and read them in Execl) but the DOUBLE value are not recognized with periodinstead of coma

ansgar's profile image ansgar posted 2 weeks ago Permalink

You need to use "Excel CSV" as output format:

Description

Please login to leave a reply, or register at first.