Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

user@localhost

dragon2611's profile image dragon2611 posted 2 years ago in Creating a connection Permalink

Any chance of supporting sending user@localhost instead of user@127.0.0.1 when connecting to MYSQL via an SSH tunnel as some versions of Mysql treats them differently and I've had some instances where user@localhost exists but user@127.0.0.1 doesn't and I have to go in with the command line utilities and at 127.0.0.1 as an allowed host before heidisql will connect.

garreh's profile image garreh posted 2 years ago Permalink

I'm having the same problem.

According to the MySQL docs - it treats connections from 127.0.0.1 and localhost completely differently - with 127.0.0.1 it uses a TCP connection and localhost uses a unix socket (much faster) - also with Grant permissions / privileges they are not equal either.

If you set "localhost" in your Heidi settings, it will automatically change it to 127.0.0.1 - it should obey whatever you've set imo. Very frustrating

Please login to leave a reply, or register at first.