Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Cannot upgrade because uninstall fails

daniel.kadosh's profile image daniel.kadosh posted 5 months ago in Installation Permalink

Somehow I got into a borked state where I cannot uninstall the current version I have. The crux of the issue is that I lost "unins000.exe", it just doesn't exist on my computer any more :-(

Two key things I've tried:

  1. Going to programs and features out of control panel, and then uninstalling from there fails because the above EXE is missing.

  2. The attached picture is what happens when I run the new installer I just downloaded. It fails with a misleading error of "access denied".

Any ideas on how to uninstall? I much prefer doing things more cleanly than simply remove the "program files/Heidisql" directory and mucking with the registry by hand. I prefer to keep my settings intact, in particular connection information and passwords, as I have quite a few.

1 attachment(s):
  • heidi1
ansgar's profile image ansgar posted 5 months ago Permalink

If the normal uninstall fails, I highly recommend removing the directory C:\Program Files\HeidiSQL\ that should be absolutely fine.

Reinstalling afterwards should give you no "access denied" error, unless you run the installer with lower privileges.

Your settings for sessions and all other stuff is localted in the registry. The uninstaller also does not delete them. And the newly installed version uses your old settings when they're still at the same key.

daniel.kadosh's profile image daniel.kadosh posted 5 months ago Permalink

That worked perfectly, THANK YOU!

Please login to leave a reply, or register at first.