Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

How to support unicode on SQL editor?

kevin99999's profile image kevin99999 posted 5 months ago in General Permalink

hi all guy please suggest me how to fix this issue

best regards

kevin

1 attachment(s):
  • hd
ansgar's profile image ansgar posted 5 months ago Permalink

That's a font issue, not an issue with the editor component. I'm not sure which font has the unicode characters you need. Did you try "Consolas"?

Description

kevin99999's profile image kevin99999 posted 5 months ago Permalink

my font is not showing like this tab

1 attachment(s):
  • sasss
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 5 months ago Permalink

You mean you don't have that "Consolas" font?

I got that along with the default Windows 10 installation here, so I think it should also be there for you.

kevin99999's profile image kevin99999 posted 5 months ago Permalink

i mean why my font phetsarath OT can not display on SQL tab , but Grid tab is showing

1 attachment(s):
  • my
ansgar's profile image ansgar posted 5 months ago Permalink

The dropdown only shows fonts which are marked as fixed pitch font. That's due to SynEdit which is restricted to such fonts.

If you want to configure another one for the SQL memos, you have to do that via registry:

  • exit all HeidiSQL instances
  • start regedit.exe
  • go to HKEY_CURRENT_USER\Software\HeidiSQL
  • doubleclick the value FontName to edit it, and put in the exact name you want, like shown below

Description

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.