Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Note (Code 1031): Storage engine InnoDB of the table xxxxxx does not have this option

chinook's profile image chinook posted 1 month ago in Import/Export Permalink

When importing dumped data produced by HeidiSQL export feature I get the following error:

Note (Code 1031): Storage engine InnoDB of the table xxxxxx does not have this option

This is data for table HeidiSQL exported:

-- Dumping structure for table recall_qa.agency_types
CREATE TABLE IF NOT EXISTS `agency_types` (
  `agency_id` int(11) NOT NULL AUTO_INCREMENT,
  `description` varchar(50) DEFAULT NULL,
  PRIMARY KEY (`agency_id`)
) ENGINE=InnoDB AUTO_INCREMENT=8 DEFAULT CHARSET=latin1;


-- Dumping data for table recall_qa.agency_types: ~8 rows (approximately)
/*!40000 ALTER TABLE `agency_types` DISABLE KEYS */;
INSERT INTO `agency_types` (`agency_id`, `description`) VALUES
    (0, ''),
    (1, 'FDA'),
    (2, 'USDA'),
    (3, 'EPA'),
    (4, 'US Consumer Product Safety Commission'),
    (5, 'Other'),
    (6, 'None'),
    (7, 'CFIA');
/*!40000 ALTER TABLE `agency_types` ENABLE KEYS */
ansgar's profile image ansgar posted 1 month ago Permalink

I get the same, with HeidiSQL v11 on MariaDB 10.3, and the message is caused through the ALTER TABLE .. DISABLE/ENABLE KEYS query. Well, it's just a warning, no error. But I should probably remove this for InnoDB tables.

Please login to leave a reply, or register at first.