Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

How to stop the database name being pasted in to query window?

JAB Creations's profile image JAB Creations posted 1 month ago in General Permalink

For some reason there is a shortcut that I keep pressing that pastes the name of the database in to the SQL query field. What is it so I can disable it with extreme prejudice?

ansgar's profile image ansgar posted 1 month ago Permalink

Just right-click the tree, go to "Tree style options" and disable "Doubleclick inserts node text":

Description

JAB Creations's profile image JAB Creations posted 1 month ago Permalink

Thank you! That was getting really obnoxious! I really would not recommend having that option enabled by default. I'm not saying get rid of it, someone somewhere really enjoys having it though from a UX perspective I think the majority of people would also find this annoying.

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 1 month ago Permalink

I wonder why you doubleclick a tree node at all? By accident?

JAB Creations's profile image JAB Creations posted 1 month ago Permalink

It expands the table list. A single left-click only selects the database.

Is there a way to make the tree expand the database with a single left-click? That'd be a nice polish to the UX.

JAB Creations's profile image JAB Creations posted 1 month ago Permalink

Oh, never mind! I just looked in the [i]Tree style options[/i] and enabled "Auto expand on click". You might want to make that the default option! ;-)

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.