Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Access violation at address 000000506A500000 in module 'heidisql.exe'

viktor.hujer's profile image viktor.hujer posted 2 years ago in General Permalink

Open table. Move to column. Press F2 to edit value. Press ESC to exit editing.

/ #1634496361: Access violation at address 000000506A500000 in module 'heidisql.exe'. Execution of address 000000506A500000 Message CharCode:27 Msg:256 /

or press Enter to close editing

/ #1634496361: Access violation at address 00000000005742AB in module 'heidisql.exe'. Read of address 0000000000000000 Message CharCode:13 Msg:256 /

Windows 10 1909 Revision 6097

ansgar's profile image ansgar posted 2 years ago Permalink

Yes, this is a known issue. See issue #1107 for details.

viktor.hujer's profile image viktor.hujer posted 2 years ago Permalink

I check issue #1107. I have 11.1.0.6122 and message

`/ #1634496361: Access violation at address 00000000007001D1 in module 'heidisql.exe'. Read of address FFFFFFFFFFFFFFFF Message CharCode:13 Msg:256 /

/ #1634496361: Access violation at address 000000506A500000 in module 'heidisql.exe'. Execution of address 000000506A500000 Message CharCode:27 Msg:256 /`

Do you know release when resolve this bug?

ansgar's profile image ansgar posted 2 years ago Permalink

I just made that message visible in the last release. It was there for a long time before, it was just not visible to the user. And I am working on that, but it's a really nasty issue.

bloodsport's profile image bloodsport posted 1 month ago Permalink

I am having a very similar problem for months now, it is driving me completely nutty. When editing data manually in a table, using F2, I get this error message. Note, the table has been filtered to reduce the number of instances I need to edit. But even with an unfiltered table, I get the same access violation message. I also get a message to download a driver each time I launch a session but I have downloaded that driver multiple times and I still get the message, even after I delete the old connection and establish a new connection.

/ #91: Access violation at address 00000000006E6E81 in module 'heidisql.exe'. Read of address FFFFFFFFFFFFFFFF Message CharCode:9 Msg:256 /

ansgar's profile image ansgar posted 1 month ago Permalink

Please ignore that message, it's just in the log panel for debug reasons.

The driver may already work. I assume you mean the one for MS SQL. You need to change the session library to "MSOLEDBSQL".

bloodsport's profile image bloodsport posted 1 month ago Permalink

Thanks but we are using SQL 2017 not MS SQL. library is set to SQLOLEDB

And the error message is not spurious, I cannot edit the field. I get a red triangle in the corner and the error message mentioned. Sometimes the window freezes up, have to ctl alt delete to get out of it.

1 attachment(s):
  • Screenshot-7-
ansgar's profile image ansgar posted 1 month ago Permalink

SQL Server is from Microsoft, so we're talking about the same (MS SQL = SQL Server)

The red triangle is displayed when you modified a grid value. Very normal. After focusing a different row, your modifications should be posted as an UPDATE to the server.

bloodsport's profile image bloodsport posted 1 month ago Permalink

Changed library to "MSOLEDBSQL" and the driver error has gone away.

But now the error message I get when manually editing data has changed. See screenshot. And upon pressing enter, the screen freezes and I cannot exit. Nothing is updated in the database.

1 attachment(s):
  • Screenshot-8-
ansgar's profile image ansgar posted 1 month ago Permalink

I see an SQL error in the log panel at the bottom, but not the line above that one:

The data types image and varbinary(max) are incompatible in the equal to operator

Please post the 3 lines above it, there must be something wrong with the internal UPDATE query.

bloodsport's profile image bloodsport posted 1 month ago Permalink

once that error appears, the application freezes here is screenshot of the query history

1 attachment(s):
  • Screenshot-9-
ansgar's profile image ansgar posted 1 month ago Permalink

I would highly recommend to create a primary key on your tblItem table. I suppose the issue is now that the UPDATE fails and internally the grid stays in edit mode. Adding a primary key should at least make the UPDATE work as expected.

bloodsport's profile image bloodsport posted 1 month ago Permalink

I thought the first column item_id was the primary key. At least that's how the table was originally set up. maybe when they migrated the database from sql2014 to sql2017 that was lost. how do I "create a primary key" retroactively?

ansgar's profile image ansgar posted 1 month ago Permalink

This is what I just found on https://learn.microsoft.com/en-us/sql/relational-databases/tables/create-primary-keys?view=sql-server-2017

ALTER TABLE Production.TransactionHistoryArchive
   ADD CONSTRAINT PK_TransactionHistoryArchive_TransactionID PRIMARY KEY CLUSTERED (TransactionID);
WiiLF's profile image WiiLF posted 4 weeks ago Permalink

I'm getting this a lot today when adding fields to a new table, but the last field I change from INT to LINESTRING and back to INT realizing a mistake with no save yet, and it raised this log message.

I develop in C# land so I can understand some internal pointers are not being read from memory or some kind of callback issue with the application in memory? I have not looked at the source code, but I can see it is available.

ansgar's profile image ansgar posted 4 weeks ago Permalink

Please ignore that message. It just sits there for debug reasons, intentionally.

bloodsport's profile image bloodsport posted 1 week ago Permalink

Ok well now I have added primary keys and was able to edit some records in certain tables using F2. But when I try to edit the field "seller_id" in the table "tbl-user", the edit screen forces me to choose from a digit followed by the term "yes" ... this field is a simple integer field, I just want to change 2 to 1.

bloodsport's profile image bloodsport posted 1 week ago Permalink

it seems i cannot edit a field that is a "foreign key" using F2 or double click

ansgar's profile image ansgar posted 1 week ago Permalink

Please post a screenshot, or explain what you mean with "i cannot edit...". What happens when you press F2? Nothing? Or does it show a dropdown box with wrong values? Or..?

bloodsport's profile image bloodsport posted 1 week ago Permalink

never mind, i figured it out, you cannot freeform a foreign key field when editing, you have to choose from the dropdown menu .. duh

ansgar's profile image ansgar posted 1 week ago Permalink

Ah I see. You may disable that dropdown in your preferences if you prefer to type text:

Description

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.