Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

All cell values in results view show "Node"

HerrimanCoder's profile image HerrimanCoder posted 2 years ago in General Permalink

I'm using HeidiSQL 11.0.0.6096. I can run queries and get correct results, but after a few minutes (and sometimes after only a few seconds), every cell in the results grid suddenly and automatically changes to "Node":

image description

If I run the query again, again I get correct results. But after a very short time, it all changes back to "Node" in every cell.

WTH is going on? Has anyone else seen this bug? Anything I can do to fix it?

BenLouw's profile image BenLouw posted 1 year ago Permalink

I get a similar issue. I VPN to a network and run queries with HeidiSQL on there and close the VPN connection. Since I upgraded to 11.1 most of the time, but not always, when I disconnect the VPN all fields are also changed to Node. This did not happen in older versions of HeidiSQL.

Coderexis's profile image Coderexis posted 1 year ago Permalink

I'm experiencing the same problem of "Node" value in all cells as described in previous posts. BTW I'm using HeidiSQL 11.1.0.6202...

Seeing that this issue was reported 2 months ago and it is still there, probably I have to go back to the version 7.

ansgar's profile image ansgar posted 1 year ago Permalink

That "Node" displaying is just a harmless fallback when the connection is broken. You should also see the upper left connection node in the left tree shows a disconnect icon. Once you refresh the grid or fire some query, the cells should display their values again.

BenLouw's profile image BenLouw posted 1 year ago Permalink

That is all very well, but it is still a bit frustrating to disconnect my VPN and then discover I forgot to copy the data I had on the screen. Then I have to reconnect and wait for the data to refresh. I don't really understand why the screen needs to refresh when the connection closes in the first place.

jeremysawesome's profile image jeremysawesome posted 1 year ago Permalink

This happens to me all of the time. The end server disconnects after about 10 seconds, sometimes less.

It would certainly be nice if Heidi cached the visible data, so that the cells don't get overwritten with "Node" when the end server disconnects.

feelie75's profile image feelie75 posted 11 months ago Permalink

Same here. There is no good reason that the results grid should change regardless of the connection status. I'm sure "someone" will come up with a reason but pretty much every post I've seen on this forum from that "someone" has been anti-helpful to the poster. Results should be STATIC and stay that way forever until you close the window or run a new query. That's how every other SQL query software I've ever seen works. If there is a way to fix Heidi SQL to do this, that would be great because as of now it's current operation is a BUG, not a design feature. Looking forward to updates on fixing this issue. Thanks! :)

feelie75's profile image feelie75 posted 10 months ago Permalink

by the way, since HeidiSQL is broken now, I found MySQL Workbench, and it works beautifully, the results stay static, and it seems to have all the same features. from the official mysql dot com website slash products slash workbench. good luck!

jeremysawesome's profile image jeremysawesome posted 3 months ago Permalink

Has anyone figured out how to fix this yet? It's terribly annoying, especially when a server drops connections every 30 seconds.

rjaquez's profile image rjaquez posted 2 months ago Permalink

Same happens to me, I solved it by changing the "Library" setting in the Session manager to libmysql-6.1.dll to match as closely as posible the server 5.6

enver.toleuov@gmail.com's profile image enver.toleuov@gmail.com posted 4 weeks ago Permalink

If you use MySQL or MariaDB you need to set higher value for timeout. Usually it happens when server closes the connection. To set timeout: SET wait_timeout = 10000

ansgar's profile image ansgar posted 4 weeks ago Permalink

That's correct.

Even easier may be to modify the ping setting in your HeidiSQL session:

Description

BenLouw's profile image BenLouw posted 4 weeks ago Permalink

Unfortunately this will not work in my case. The problem is not that the server closed the connection, but that the server is no longer available, because I connected to it over a VPN that is no longer connected.

jeremysawesome's profile image jeremysawesome posted 4 weeks ago Permalink

I'll look into these things. However, one option would be for Heidi to not clear any information until a new query is sent.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.