Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

"Stop on errors in batch mode" - where is it?

Katy's profile image Katy posted 1 year ago in General Permalink

Hi,

I'm executing a large SQL file (creating a DB from a DB export) and I get the message in the attached screenshot. Where exactly do I find the highlighted option?

Description

Thanks, Mircea.

ansgar's profile image ansgar posted 1 year ago Permalink

It's the button with the warning sign, on the main toolbar:

image description

Katy's profile image Katy posted 1 year ago Permalink

Ouch, didn't think of that, I kept digging for it in preferences. Thanks :)

UweKeim's profile image UweKeim posted 1 year ago Permalink

Was searching in the settings, too.

BTW: In Dark Mode (and via RDP), the checked and unchecked icons literally look the same. Tooltip doesn't change, too. This is literally a try-and-error approach.

kdreally's profile image kdreally posted 12 months ago Permalink

in my case the underlying cause of this was that one of the tables had a BLOB column and it had huge content. you can either filter out that column (or table) from the dump, or you can increase the value of max_allowed_packet (default 4M) to something large like 500M.

phamduchuy552's profile image phamduchuy552 posted 9 months ago Permalink

It's the button with the warning sign, on the main toolbar:

image description

Thank you so much

eflames's profile image eflames posted 6 months ago Permalink

@UweKeim dude u saved me!! hahahaha I pressed the button in dark mode like 100 times xDDD

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.