Database views do not update even when forcing a refresh

RickKukiela's profile image RickKukiela posted 2 years ago in General Permalink

This has caused me a lot of wasted time. I have code that makes changes to a database, sometimes its data, sometimes its structure but constantly it occurs that Heidi starts effectively "lying" to me about what is there and I will spin my wheels trying to figure out why my code is not working correctly when in reality Heidi is just not showing the real information.

Some times I can refresh at the database level and this will usually fix missing structure changes, like new columns being added. However when the problem is missing data I usually end up having to fully restart the program for it to acknowledge the changes.

Please look into this as this has been driving me crazy every time it happens.

ansgar's profile image ansgar posted 2 years ago Permalink

I already solved that recently, in issue #1628.

Please update to the latest build or wait for the next official 12.2 release.

RickKukiela's profile image RickKukiela posted 2 years ago Permalink

Amazing. Thank you! Will using the in-app updater that wants to update me to 6566 include this change? If not can you provide me a link to download the build with the update?

RickKukiela's profile image RickKukiela posted 2 years ago Permalink

Never mind, it appears that 6566 is the latest nightly so I will do that.

ansgar's profile image ansgar posted 2 years ago Permalink

Exactly, that's the newest build.

Just note that builds 6565 and 6566 have an issue in the build updater binary, so you will need to do the following update by downloading from here.

RickKukiela's profile image RickKukiela posted 1 year ago Permalink

Just FYI, I Had been running 6566 for a while now and the bug is still present. I just ran this query in a query tab for my active database:

UPDATE `product` SET images = '[]';

The query executed successfully (supposedly) and all manner of refreshing showed the all rows of that column in that table as "[]" as if it worked. However my external app that I'm developing was not seeing this change. I had to physically close and restart the app to find out the query was never actually ran on the table and was again being "lied" to...

I just updated to the latest stable release (12.4.0.6659) so I will see if this has been resolved in this version by reporting back if I experience the issue again.

WiiLF's profile image WiiLF posted 12 months ago Permalink

This happened today for the first time (using this app for 3 years solid). Which was immediately obvious as I am populating my table elsewhere. Several refreshes in both the treeview, listview and other split panels. It had me completely puzzled as it was critical to see the table fill up with data through testing. If there is caching involved, how do we disable that?

Please login to leave a reply, or register at first.