Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Screen Licked Full and Cannot Change or Move

PCHome's profile image PCHome posted 2 months ago in General Permalink

I have a little problem. After updating HeidiSQL last week, I can no longer move or resize it. It seems locked on top in full screen for some reason and even grabbing the edges to try to make it smaller does not work. I'm running the latest WINE on Ubuntu Studio and HeidiSQL as always worked well on WINE with only a couple small glitches to the inline editor. Otherwise it works as though it were made for Linux!

Also but not a big problem, the built-in updater does nothing. However, if I select the build updater, that works.

Please advise.

PCHome's profile image PCHome posted 2 months ago Permalink

Should have been "screen locked". Anyway, any update on this? I need to use HeidiSQL but cannot until resolved.

ansgar's profile image ansgar posted 1 month ago Permalink

I'm sorry, I have no helpful advice here.

Only you could check out the latest nightly build for which I am now using the latest compiler version (Delphi 11.2). This includes numerous bugfixes in the controls and components used in HeidiSQL. Probably that window thing is solved through these updates.

Note that the updater dialog disables the release link, if you already have it. The link just does not quite look like disabled, but it is:

Description

TTSneko's profile image TTSneko posted 1 month ago Permalink

While you wait for an answer please allow me to offer some advice, from Linux to Linux user: drop WINE. It's neither an emulator, nor even fully operational, and even their gold status for "supported" programs means nothing.

From experience (Linux/WINE/Heidi) and my own frustrating rides with my 80k title music library under Linux (not one music library under Linux is in any way usable for large, deep libraries) I know exactly how one feels when you can't find good software under Linux. My music problem was eventually solved by dual booting as to use MusicBee for windows; my mySQL/mariaDB/SQLite3 problems however nearly drove me insane. Not only thanks to WINE but also due to the numerous goblins in the background which constantly manipulated dependencies under Linux, resulting in some booboo or the other. As my fulltime job heavily relied on database operations my Linux systems soon required more maintenance than any of my former Windows systems ever required. I was simply not willing to risk my neck and job further by trusting useless junk like WINE.

Do yourself (and your data) a favor and get hold of a reliable, stable multi-platform programm that does not require some half-assed attempt of pseudo-interfacing Windows. I've been using DBeaver under Ubuntu (provided on-site as Debian- or RPM- download) for ages now and it never let me down, be it for my private DB data nor the humonguous multi-table jobs required for my work.

Without doubt Heidi is a fab job but it is made under (and for) Windows. Don't expect anybody to help with what in the end may (once again) turn out to be a WINE-related problem.

PCHome's profile image PCHome posted 1 month ago Permalink

WINE is not supposed to be an emulator as the acronym says: Windows Interface Not Emulator. It uses actual Windows components albeit a limited version of them.

That said, HeidiSQL supports WINE so it is not an accident or by chance that it runs on WINE.

PCHome's profile image PCHome posted 1 month ago Permalink

Ansgar, I've been running the latest nightly build each time and tried it again just now but still cannot resize or move it. It is still full screen which apparently started with the system upgrade to Ubuntu 22.10 but I am not sure.

PCHome's profile image PCHome posted 1 month ago Permalink

I guess I'm dead in the water until this has been resolved as I cannot see the screen to be able to do any other work.

ansgar's profile image ansgar posted 1 month ago Permalink

Well then I can only make wild guesses about the Wine version, which has been relevant for several graphical issues in HeidiSQL many times before. Is it Wine 7.x? I read from other users in the bugtracker using Wine 7.x successfully, with only minor glitches.

PCHome's profile image PCHome posted 1 month ago Permalink

I'm running WINE 7.0.1.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.