Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Question regarding dialog for connecting using ssh tunnel

iksi's profile image iksi posted 3 weeks ago in General Permalink

Hi,

Regarding this dialog, see attached image.

I've used this dialog for first time,

and didn't succeed to connect,

with same same settings that work fine in "MySql workbench".

After a lot of attempts, trying with various parameters (and nothing worked),

I've noticed that the "ssh executable" combobox/dropdown is has no value,

and then selected "plink.exe" and it worked immediately.

So I have question/suggestion.

Is this supposed to connect, when there's no value ?

Namely selecting "plink.exe" just over-writes an existing default value ? (ssh/plink)

If yes, then for me it didn't work without selecting, maybe there's a log to check ?

If no, then I suggest to disable the "Open" button, till there a selected value in the combo-box,

(and/or any other required values in this dialog).

Thanks for your help,

Si.

1 attachment(s):
  • HeidiSQL_12_4_64_SessionManager
ansgar's profile image ansgar posted 3 weeks ago Permalink

Yes, this is definitely not as it should be.

Next build will auto-set the first available one from the dropdown.

Code modification/commit bff590e from Ansgar Becker <anse@heidisql.com>, 3 weeks ago, revision 6662
Auto-set the first SSH executable from the dropdown when user activates SSH tunnel checkbox. See https://www.heidisql.com/forum.php?t=40399
iksi's profile image iksi posted 3 weeks ago Permalink

Ok, thank you for your quick reply !

Much appreciated.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.