Charcoal Dark Slate theme

notHeidi's profile image notHeidi posted 5 months ago in General Permalink

Hi

I like the Charcoal Dark Slate theme in Heidi, except that in the data export window the progress table is all but unreadable - please see the attached screenshot.

Hardly an imperative-to-fix bug, but If the text colour could be updated that'd be great!

cheers Phil

1 attachment(s):
  • heidi_export_window_charcoal_dark_slate_theme
Code modification/commit 8507c85 from Ansgar Becker <anse@heidisql.com>, 5 months ago, revision 12.6.0.6767
Enhance readability of focused text in result grid using dark styles. TreeOptions.PaintOptions.toGhostedIfUnfocused grays out text otherwise. See https://www.heidisql.com/forum.php?t=41458
ansgar's profile image ansgar posted 5 months ago Permalink

Well I cannot change the style with its colors, without breaking other thing. That unreadably text only applies for the focused row in the unfocused result grid. I fixed this by auto-focusing the result grid after the user has started the process, which should then look better.

notHeidi's profile image notHeidi posted 5 months ago Permalink

Thanks

head's profile image head posted 3 months ago Permalink

Description

Hi. Point me please to preferences to fix this annoying color inconsistency.

ansgar's profile image ansgar posted 3 months ago Permalink

No issue here, with the same style:

Description

Are you on the latest version? If not then please update.

head's profile image head posted 3 months ago Permalink

screen

Just updated. Sorry, no luck. Maybe I should reset theme settings somehow, uninstall app and install again or whatever?

notHeidi's profile image notHeidi posted 3 months ago Permalink

Just to say: it's good for me - v 12.6.0.6783. Just the usual update did it.

ansgar's profile image ansgar posted 3 months ago Permalink

@notHeidi: thanks for the feedback.

@head: that's strange, indeed. On which Windows version are you?

You may of course reset the theme to the default "Windows" style, in Tools > Preferences > General.

head's profile image head posted 3 months ago Permalink

Windows 10 Pro 22H1. Tried reset already, Charcoal seems not resetted. Will try to backup servers list and made clean install, report then.

head's profile image head posted 3 months ago Permalink

22H2 sorry, mistyped

ansgar's profile image ansgar posted 3 months ago Permalink

As said above, just change the style in Tools > Preferences > General > Style Theme, to "Windows".

head's profile image head posted 3 months ago Permalink

Oh my. Solved by swithcing from Aero Lite Windows theme to standart Windows 10 one. Not Heidi issue, sorry.

ansgar's profile image ansgar posted 3 months ago Permalink

Just for the records: I still meant "Windows" style, not "Windows 10" or something else... The "Windows" style is a special default one, and means "no styles".

head's profile image head posted 3 months ago Permalink

ansgar, i got it. I mean is was system-related issue with non-default themes, just for those who may meet same issue.

Please login to leave a reply, or register at first.