Doesn't start under MacOS

[expired user #3732]'s profile image [expired user #3732] posted 16 years ago in jHeidi (discontinued) Permalink

jHeidi Alpha 3 Update 4 doesn't start under MacOS 10.5.5: The console says

Exception in thread "main" java.lang.NoClassDefFoundError: com/rendion/ajl/AjlScript

Hope you can find the bug (or tell me what I'm doing wrong) because I think this is going to be a great program!!! :-)

[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink
Hi did you download the mac OSX installer or the universal binary?
[expired user #3732]'s profile image [expired user #3732] posted 16 years ago Permalink
Well, I tried both :-)

I think the "installer" doesn't really install something, does it? It's just an application (after unpacking I just get a folder containing "") and if I start it (for example from the Applications folder) some icon appears in the dock but dissapears at the same time again.

When using the universal binary I get the error mentioned above...
[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink

I just tested both on MAC OSX 10.5.2 and had no problems. The installer is in the OSX App format and is a simple archive however because of its format it runs automatically without having to run a script.

I do not have access to 10.5.5 but I would be surprised if there was much of a difference unless the Java Application Stub in 10.5.5 is incompatible.

If you downloaded jHeidi on the day of this release, you may need to download again as there were some files out of date on the day it was released which were fixed shortly after.

Either way the universal binary should work. Please give me the command you are running to start jheidi and paste in any output.
[expired user #3732]'s profile image [expired user #3732] posted 16 years ago Permalink
I downloaded it again while writing my last post and it still didn't work.

I used the jheidi-osx script to start it (doubleclick on it) which does not work: A console opens which says:
/Users/julian/Downloads/jheidi-bin/jheidi-osx ; exit;
Exception in thread "main" java.lang.NoClassDefFoundError: com/rendion/ajl/AjlScript

But what I just tested: When copying the content of this jheidi-osx script and inserting it into the console, it works... :? The console says in this case:
$ java -DstartEDT=true -Dapple.laf.useScreenMenuBar=true -Djava.library.path=lib -Xdock:name="JHeidi" -DusePrecompiledClassFiles=true -cp lib/quaqua.jar:jheidi.jar:lib/ajl.jar:lib/swing-worker-1.1.jar:lib/editor.jar:lib/mysql-connector-java-5.0.7-bin.jar:lib/log4j-1.2.13.jar -Dlog4jconfig=logs/log4jconfig.xml com.rendion.ajl.AjlScript jheidi
configuring logging from system property log4jconfig=logs/log4jconfig.xml
version=Alpha 3 Update 4
releaseNotes=jHeidi Alpha 3 Update 4 Release Notes
New in this release is the Auto Update functionality
allowing you to check for updates and install newer versions
of jHeidi.
Change Log:
338: timestamp value '0000-00-00 00:00:00' causes exception
333: database names are not properly escaped
fix download url
add user agent to http calls
Fix broken urls
create table field list broken
create table dlg: add error messages for adding a field
launch java download link when NSIS cant find Java
add popup error when NSIS cant launch java
fix null pointer when saving table with one field
make autoupdate check async
Add error handling for autoupdate check
ajl.cmd was not a variable
fix bug in bash scripts
fix error on initial run from source because classes dir doesnt exist
fix osx startup scripts
add prop files for src download
add autoupdater tasks
add setup-exe upload target
delete misplaced file
keep log.xml in log dir so svn downloaders can run jheidi as is
add required libraries to build
add innosetup to build process for windows setup.exe
add jheidi.exe make to build
fix windows cmd args
fix several build errors
remove uneccesary file extension
moved rel notes to etc
autoupdater moved to its own project
add osx java launcher
add jheidi jar launcher
add jheidi jar manifest

Do you have installed the Java for Mac OS X 10.5 Update 1 (more info: Perhaps this causes some problems...
[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink

The jheidi-osx script is meant to be run from the command line not double clicked since its not an OSX shortcut.

If you want to double click to run, then install the .app and double click on it .app and it will startup using the JavaApplicationStub which is required to graphically run a java .app on OSX.

Glad you got it working! Still puzzled why your the didnt work tho.

- Bill
[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink
The correct way to launch the script is to chmod 777 jheidi-osx

And then execute it like so ./jheidi-osx

- Bill
[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink

Finally tested the install on OSX 10.5.5 - and had no problems with running the

Using safari the app self extracts and when you click on the icon it will start.

With firefox save to your desktop, double click the archive and it will self extract.

- Bill :D
[expired user #2297]'s profile image [expired user #2297] posted 16 years ago Permalink

I'm also struggling with the immediately disappearing icon problem when trying to start in my /Applications folder. After app failed to start, this is what I get in Console:

11/3/08 13:25:18[158] ([0x0-0x3bd3bd].com.rendion.ajl.AjlScript.1[45882]) posix_spawnp("/Applications/", ...): Permission denied 
11/3/08 13:25:18[158] ([0x0-0x3bd3bd].com.rendion.ajl.AjlScript.1[45882]) Exited with exit code: 1

I downloaded OS X Installer several hours ago and I'm also on 10.5.5. Let me know if you need me to try something on my system.

[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink
On my tests on 10.5.5 this has not happened.

Seems like chmod-ing the JavaApplicationStub might be a fix.

chmod 777 JavaApplicationStub

- Let me know if that fixes you.
[expired user #2297]'s profile image [expired user #2297] posted 16 years ago Permalink
Yep, that fixed it.

Thanks :)
[expired user #3375]'s profile image [expired user #3375] posted 16 years ago Permalink
I have been doing the OSX and Linux builds on windows, which I believe is the cause for the loss of the execute bit on the JavaApplicationStub and the jheidi-osx script and the jheidi-bin script on linux.

I will start doing the builds on linux and this should go away in the next release.

Thanks for reporting the precise error.


Please login to leave a reply, or register at first.