can't connect to mysql (on windows server 2008 r2) sql instance not running

Vroomco posted 5 years ago in General
Please help with some solution.
I restarted windows server and after that getting error when connecting to mysql administration and can start mysql server instance...
Vroomco posted 5 years ago
additional info so not to get some simple solution:
mysql run for long time and it is set to Automatic startup with Windows. many forums are giving few solutions but seems it is not relevant to this problem. mysql administration can't be open due to mysql instance not running. need to get solution first on how to start instance mysql running as seems there is some issue with TCP or else...
ansgar posted 5 years ago
- Start cmd.exe
- run "net start mysql"
Vroomco posted 5 years ago
1067 error - i tried manually from Services window...not but got some log file here:
120614 6:38:17 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: Error: log file .\ib_logfile0 is of different size 0 268435456 bytes
InnoDB: than specified in the .cnf file 0 536870912 bytes!
120614 6:38:18 [ERROR] Plugin 'InnoDB' init function returned error.
120614 6:38:18 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120614 6:38:18 [ERROR] Unknown/unsupported table type: INNODB
120614 6:38:18 [ERROR] Aborting
Vroomco posted 5 years ago
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
0000000140007ED0 mysqld.exe!memcpy()[memcpy.asm:272]
000000014011BBEA mysqld.exe!String::append()[sql_string.cc:459]
0000000140057A29 mysqld.exe!thd_security_context()[sql_class.cc:387]
0000000140209537 mysqld.exe!innobase_mysql_print_thd()[ha_innodb.cc:794]
000000014021704F mysqld.exe!trx_print()[trx0trx.c:1764]
00000001402382BD mysqld.exe!lock_print_info_all_transactions()[lock0lock.c:4297]
0000000140213DAF mysqld.exe!srv_printf_innodb_monitor()[srv0srv.c:1695]
000000014020FBE9 mysqld.exe!innodb_show_status()[ha_innodb.cc:7223]
000000014009C092 mysqld.exe!ha_show_status()[handler.cc:4417]
000000014006A87D mysqld.exe!mysql_execute_command()[sql_parse.cc:2426]
000000014006E8A6 mysqld.exe!mysql_parse()[sql_parse.cc:5935]
000000014006F43A mysqld.exe!dispatch_command()[sql_parse.cc:1215]
00000001400700A7 mysqld.exe!do_command()[sql_parse.cc:854]
00000001400965B7 mysqld.exe!handle_one_connection()[sql_connect.cc:1127]
0000000140315B25 mysqld.exe!pthread_start()[my_winthread.c:85]
00000001402DFDA7 mysqld.exe!_callthreadstart()[thread.c:295]
00000001402DFE75 mysqld.exe!_threadstart()[thread.c:275]
00000000772D652D kernel32.dll!BaseThreadInitThunk()
000000007750C521 ntdll.dll!RtlUserThreadStart()
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 000000007B2ECB90=SHOW INNODB STATUS
ansgar posted 5 years ago
There you got it: Your file .\ib_logfile0 has a wrong size. According to this user you should delete any .\ib_lofile* file and try to restart the server then.
Vroomco posted 5 years ago
Yes...that worked . deleted both logfiles - 0 and 1
Now only to check if i have data from before after deleting it
Thanks a lot for this Hint

Please login to leave a reply, or register at first.