Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

HeidiSQL automatically comes to the front when opening -- How to prevent this

WaveLength's profile image WaveLength posted 7 years ago in General Permalink
Often, my internet connection is very slow. Therefore, when I open browser tabs etc, I don't want to wait for them, so I Alt-Tab to another program to continue working without a break.

I do the same with HeidiSQL: After the Session Manager screen, I often have to wait 15 or 30 seconds to get connected with my remote databases. Anyway, by force of habit, I switch to another program to continue working, and then return to HeidiSQL after a minute or so.

Here's the problem: When HeidiSQL finally does get connected, it automatically comes to the front. So if I'm typing something in another program, it ends up getting typed in HeidiSQL instead. This can be dangerous. I don't want to accidentally delete or modify data or settings in HeidiSQL.

Is there any way to make HeidiSQL open my remote databases without the program window automatically jumping to the front?


Please login to leave a reply, or register at first.