Database showing 0 B in size

jivory posted 4 years ago in General
I'm having an issue with a database showing up. I've used HeidiSQL for a while now, connecting to the same DBs. The last few days I've not been able to pull up a specific DB. My connection is the same, and other, smaller DBs still show up, but our 'large' DB does not. I'm unsure of the size, but I know it's sever Gig.
This issue only happens on my machine, and another co-worker's, both using Windows 7. Everyone else is either on Linux or a Mac, and they have no issues.

Has anyone ever seen this issue? I'm wondering if the DB reached a size limit that Windows cannot handle. This seems odd, but the only logical explanation right now.
ansgar posted 4 years ago
Are you talking about the tree on the left, right besides the databases? Maybe send a link to a screenshot?

Could you say more exactly how big that db is? And, more important, what HeidiSQL revision you are using, and what server version it is.

I just thought you hit the 32 bit limit for some integer variable in HeidiSQL, but I also have a larger database with ~3gb in it, which does not have that problem.
jivory posted 4 years ago
I try running:
SELECT table_schema "Data Base Name", sum( data_length + index_length ) / 1024 / 1024 "Data Base Size in MB"
FROM information_schema.TABLES GROUP BY table_schema ;
to get the size, and it fails with a 2013 error, so I'm not sure the exact size, but I want to say somewhere around 20G.

I tried another program, SQL Wave 6, and when I try to load this DB, it freezes up (Not Responding), but the other DBs work just fine.

Is there some setting in my.ini I could change to increase size or cache? Something like that, that would be killing the connection trying to connect to this specific DB?
jivory posted 4 years ago
And yes, I'm talking about the tree on the left. It shows not tables, and says 0 B. But I know that my XAMPP connects and uses the DB, because my local environment work, and I can even make queries within HeidiSQL, it just won't show me the tables or info.
ansgar posted 4 years ago
You said the IS query returns with a "2013 error". What's the exact error message? Perhaps there is a hint to what's going on here.
jivory posted 4 years ago
SQL Error (2013): Lost connection to MySQL server during query
jivory posted 4 years ago
I don't get any such error using the SQL Wave 6, it just freezes, so at least HeidiSQL gives me an error to help try and figure it out haha
ansgar posted 4 years ago
There must be some broken file in your database directory. You should try to run "REPAIR TABLE yourtable" for all of your tables.
jivory posted 4 years ago
Thanks, I'll give that a try. I downloaded a trial of Navicat, and it loads everything just fine, so maybe it is a size limit or something that Windows isn't liking.
coryldean posted 4 years ago
I am having this same issue.
Looking at the console when trying to select a DB, it shows this:

/* Entering session "SESSIONNAME" */

/* [SESSIONNAME] Connecting to HOSTNAME/IP via MySQL (TCP/IP), username USERNAME, using password: Yes ...*/

/* [SESSIONNAME] Connected. Thread-ID: 4951 */


/* [SESSIONNAME] Connection to HOSTNAME/IP closed at YYYY-MM-DD HH-MM-SS */
jivory posted 4 years ago
My solution was, making work purchase Navicat, which loads my db just fine.

I'm able to load a db that's 1.4GB, but our large one that's around 16+GB, is the one that has issues, doesn't show anything and displays 0B.

Maybe it was something with an update? It worked great a few months ago, I've kept regular updates, and just stopped working one day.

I have not tried on Mac or Linux, so it still could be some Windows issue.

Please login to leave a reply, or register at first.