Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

r4504: decimal fields have to be entered with "." now (de locale), was ","

jfalch's profile image jfalch posted 9 years ago in Feature discussion Permalink
on a system using german locale (/number settings), I suddenly have to enter decimal fields using "." to separate decimal places. Not a big deal to me, but I liked "," better... something to do with the "Edit raw numbers" change of 4504 ?
ansgar's profile image ansgar posted 9 years ago Permalink
You can activate Tools > Preferences > Data appearance > "Local number format". But editing, copying and pasting consequently uses unformatted numbers. See issue #3324 for discussion and bugreports on that topic.
hogue's profile image hogue posted 8 years ago Permalink
Hello jfalch,

have you been able to solve this problem? I just have the same problem. Activating "Local number format" displays decimal with "." (point), but when inserting data in a fieldtype "decimal" heidi separtes the data with "," without ". So sql say Error 1136

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.