Editing a date field crashes

fusioned posted 4 years ago in General
I'm trying to edit a date or datetime field in the Data grid page, but pressing enter or double clicking on the field causes HeidiSQL to crash.

My version of HeidiSQL is 64bit.

One of the fields is setup as a datetime with a default of 0000-00-00 00:00:00. This is in an InnoDB table if that matters, with a collation of latin1_swedish_ci.

I can highlight the box using the cursor keys. It doesn't matter whether the field has an existing date (e.g. 2010-04-05 18:10:01) or if it is a date (no time) field. It's not specific to that table (I've tried other similar tables with date columns).

Timestamp fields seem ok. Date/datetime fields in MyISAM tables work ok.

Interestingly enough, in the same database, datetime fields in InnoDB + utf8_general_ci collation is ok.

So just to summarise after testing against other databases / tables:

One particular database, with a table set to InnoDB + latin1_swedish_ci.
Timestamps are ok, but date and datetime editing causes heidisql to crash with:

Problem signature:
Problem Event Name: APPCRASH
Application Name: heidisql.exe
Application Version:
Application Timestamp: 52e3931a
Fault Module Name: USP10.dll
Fault Module Version: 1.626.7601.18009
Fault Module Timestamp: 50adbbd0
Exception Code: c0000005
Exception Offset: 000000000006de38
OS Version: 6.1.7601.
Locale ID: 2057
Additional Information 1: 08a7
Additional Information 2: 08a73274d0cf5a5532231bf8fde28962
Additional Information 3: 6a53
Additional Information 4: 6a532e50facd8b21a2c15413b72fb865

Other local databases with this combination seem ok. I've already tried to optimize/analyse/recreate this table.


Please login to leave a reply, or register at first.