distal-attribute
distal-attribute
distal-attribute
distal-attribute

Importing langlink.sql and increasing chunk size

tomthirteen posted 3 months ago in Import/Export

Hi, has anyone had experience loading langlinks.sql to heidisql? I'm trying to load the arabic sql and it gets through most of it then I get "end of file block was cut within some multibyte characheter, at position x. increasing chunk size and retry" but it just keeps retrying to no avail I don't know how to increase the chunk size. It's UTF-8, and I've tried different ways, such as load and sql files. I've tried to load it and not load into the editor.

Any help is appreciated.

Misha v.3 posted 3 months ago

Unfortunately, I do not know what langlink.sql is and how big is it. I've loaded ~250MB dumps using heidi many times and never faced such error.

However, there are quite a few old discussions about the issue in the forum. One example

Not sure if it is fixed in Delphi now or some in-heidi workaround is used. Looks like you only can try to load sql with specifying UTF-8 encoding explicitly and if it fail use mysql CLI.

tomthirteen posted 3 months ago

Misha,

Thank you for the answer. I'm dealing with the interlanguage links files for each language database in Wikipedia. When I specifically save the file for Arabic as UTF-8, its size is over 442 MB. Now the error message is error-1114-the-table-is-full. I am having problems finding solutions for this. I keep trying to reset the table size, but it's not helping. I've tried SET GLOBAL tmp_table_size = 1024 1024 1024 2; SET GLOBAL max_heap_table_size = 1024 1024 1024 2; but it's not helping. I've also tried:

SET GLOBAL max_heap_table_size=10000000000; SET GLOBAL tmp_table_size=10000000000; SET max_heap_table_size=10000000000; SET tmp_table_size=10000000000;

Again not helping. If anyone has any suggestions, I'd be very grateful. I'm searching for answers, too.

Thanks! Tom

Misha v.3 posted 3 months ago

Do you have max:xyz specified in innodb_data_file_path? If so try to remove or increase it. Do you have enough space where you data dir and temporary tables are stored? If innodb_file_per_table is NOT ON, what is the size of ibdata1 file?

These might help:

show variables like 'innodb%'

https://stackoverflow.com/questions/730579/error-1114-hy000-the-table-is-full

kalvaro posted 3 months ago

I think the end of file block was cut within some multibyte characheter is specific to HeidiSQL and there isn't much you can really do about it, except maybe adding whitespace here and there until you're lucky and it stops happening.

No idea of how the program internals handle chunked file reading exactly but the increasing chunk size and retry is kind of scary. Stripping the orphan byte and prepending it to next chunk might work better.

ansgar posted 3 months ago

When you load the sql file, did you try to select the utf8 encoding in the drop down? That "Auto detect" encoding is buggy, really. Don't use "Auto detect" when you are sure about the encoding in your file.

tomthirteen posted 2 months ago

Yes, I set it at UTF-8

tomthirteen posted 2 months ago

Hi, I am getting "SQL Error (1021): Disk full (C:\Windows\SERVIC~2\NETWOR~1\AppData\Local\Temp#sql69c_3_a4.MAI)" So, the disk space is full. I am working in heidisql in windows. I can't find where these files are. I can't seem to figure out how to increase the space. Googling seems to provide solutions for linux. Any suggestions are much appreciated!

Misha v.3 posted 2 months ago

By default all MySQL data located at "C:\ProgramData\MySQL\MySQL Server X.X\Data\"

Check your MySQL variables or my.ini to find where is your data dir (if MySQL is installed as a service you can find path to my.ini in MySQL service properties).

You can use WinDistStat or similar program to locate what is using your disk space.

tomthirteen posted 2 months ago

Thank you SO much for your help. That suggestion resolved that issue. Now another.

I wanted to save all my data to an external because I'm working with large amounts of data. When I ejected the external and then reconnected it, HeidiSQL wouldn't work. Now all I get it "SQL Error: can't connect to MySQL server on '127.0.0.1' (10061)." I see in the services status window that it's now stopped. Everything is grayed out, and I can't figure out how to start it again. I'm googling as we speak.

I'm sorry for these questions. I'm a newbie to HeidiSQL

1 attachment(s):
  • error_heidisql
tomthirteen posted 2 months ago

Sorry, the attachment is below

1 attachment(s):
  • error_connection
Misha v.3 posted 2 months ago

You might want to double check that you started the services console as Administrator or check SQL log files and SQL related messages in Event Viewers.

Please login to leave a reply, or register at first.