Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Import Excel CSV double quote sign

HofMar's profile image HofMar posted 2 years ago in Import/Export Permalink

The import function for Excel csv did not work with quote sign.

The Export function double every quote sign and add the encloser. So if the field separator is ; and the encloser is " the following column

"test"

will correctly exported as

"""test"""

With the same Settings (fields terminates with ; and fields enclosed and escaped with ") this csv will be interpreded as

""test""

That is wrong. I try the current Version 9.5.0.5226.

Thanks Martin

ansgar's profile image ansgar posted 2 years ago Permalink

Excel should import """test""" as "test", as the one doublequote escapes a following doublequote.

Just to be sure I understand correctly, as this escaping stuff is confusing: You are now saying that Excel interpretes """test""" as ""test"", or?

HofMar's profile image HofMar posted 2 years ago Permalink

No this isn't a problem with Excel. The problem occures if i import to HeidiSQL an export from HeidiSQL. As Format a choice the Excel csv with the above Parameters.

Normally Excel don't quote the data. Only if Special character are used, the quoting is used.

Misha v.3's profile image Misha v.3 posted 2 years ago Permalink

Not really sure what's wrong. I created a table with single text column and put in the column something that have quotes. Then I exported the content into a csv file. I checked that quotes are doubled. Then I go Tools | Import CSV file, selected the file and uploaded into the same table with 'truncate' option checked. The content in the column as it should be.

Could you explain how we can see the issue?

Please login to leave a reply, or register at first.