Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Export row grids in Excel CSV is placing quotes around the first row.

mseeds's profile image mseeds posted 3 weeks ago in General Permalink

Since version 11.1 (I'm on 11.1.0.6119) when exporting to Excel CSV the first row/column has quotes around the first entry.

1 attachment(s):
  • heidisql
ansgar's profile image ansgar posted 3 weeks ago Permalink

You may need to select ANSI encoding for your version of Excel.

mseeds's profile image mseeds posted 3 weeks ago Permalink

I'm copying to clipboard and this happens on both Excel and Google Sheets. This also happened after the last upgrade.

ansgar's profile image ansgar posted 3 weeks ago Permalink

Did you follow my encoding hint?

TJO's profile image TJO posted 3 weeks ago Permalink

I have the same problem. I made sure that the standard encoding of Excel is set to "Westeurope (Windows)", but this did not solve the issue. The value in most upper-left cell always appears in quotation marks when inserting results from the clipboard that have previously put into the clipboard by Heidi`s "export as Excel CVS" function. This is not the first time I come across this issue. However, in the past I could heal this behaviour by deinstalling and reinstalling HeidiSQL. This time however that method does not work either.

ansgar's profile image ansgar posted 3 weeks ago Permalink

What about my hint for selecting ANSI encoding in HeidiSQL's export dialog?

TJO's profile image TJO posted 3 weeks ago Permalink

Thanks for your quick reply.

Yes, the export dialog shows "Encoding: ANSI" (please refer to attached screenshot).

Actually I cannot even change that setting while "Copy to clipboard" is selected.

1 attachment(s):
  • screenshot
ansgar's profile image ansgar posted 2 weeks ago Permalink

Oh, got it - I overread you were referring to the Copy to clipboard option, not the file option. So we have a new issue here, broken for solving issue #1077. I was adding a UTF8 BOM for both the file and the copy option, but it should only be added in file mode. I am going to fix that.

Code modification/commit 033041c from Ansgar Becker <anse@heidisql.com>, 2 weeks ago, revision 6128
Issue #1077: add UTF-8 BOM in Excel output only in file-mode, not in copy-mode. See https://www.heidisql.com/forum.php?t=37190
ansgar's profile image ansgar posted 2 weeks ago Permalink

Should be fixed in the next build.

TJO's profile image TJO posted 2 weeks ago Permalink

Dear Ansgar.

I can confirm that with build 6128 the issue is fixed (at least on my system). Thank you very much for solving this so quickly!

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.