varchar default value as empty string

Saturday3AM posted 9 years ago in General
I need to have an empty string as default value in several varchar columns but leaving the defaultvalue-field empty does not work. I'm 99% sure it has worked before in a previous version but then I had to write something and then delete it for it to be an empty string. Now it appears to not work not whatever I do, is there any way around it?

This is using the main version 3.2. I tried the latest build (1739) as well but it appeared to be trimming the field and not even let me put a space in it. When I tried to put a _ in the field it gave me a syntax error like this: '_ NOT NULL'.

Besides this little cloud in the sky, the program is great! Any help appreciated!
rosenfield posted 9 years ago
Using r1739, put in '' in the default value field.

An empty field means no default value.
A pair of single quotes means default value is a blank string.
Putting in NULL without quotes means default value is NULL.

You cannot put in functions such as GETDATE() in the default value field, since MySQL Server does not support this.

If you have suggestions for improving the user experience in the new version, feel free to post them. Preferably thought-through an at http://rfe.heidisql.com/ ;-).

Please login to leave a reply, or register at first.