Having Problems

vgug posted 8 years ago in General
I was using HediSQL for 2 years or so. Then the very unfortunate happened a few weeks ago, the computer I was using died.

I have most of everything up and running like I was before but the only thing I can't get running right is HediSQL. The program opens up and starts like it did before, however after I try and connect I get

EAccessViolation: Access violation at address 00669A5A in module 'hedisql.exe'. Read of address 00000000

I then decided to uninstall that and try to install the older version and I get this

Access violation at address 0063CD68 in module 'hedisql.exe'. Read of address 00000000.

Is there something I forgot, I double checked the host mysql name and user and password.

Thank you for the help in advance.
ansgar posted 8 years ago
HeidiSQL version / revision?
vgug posted 8 years ago

HeidiSQL version / revision?

the one I have installed right now is Version 3.2 Revision: 1129

this one is giving me the 2nd error. I had the 4.0 version installed giving me the other error
ansgar posted 8 years ago
Hm, I can only guess here. You could try and rename HeidiSQL's registry key to fix a potential broken registry key or value:

1. Quit all HeidiSQL instances
2. open regedit.exe, browse to HKEY_CURRENT_USER\Software\HeidiSQL
3. Rename "HeidiSQL" to "HeidiSQL__" or whatever
4. start HeidiSQL

Problem solved?
vgug posted 8 years ago
nope, still getting the same errors. Is there something I could be missing?

I just need the installer, correct?
ansgar posted 8 years ago
Weird.. then you could try to
1. uninstall all HeidiSQL versions
2. erase your c:\program files\HeidiSQL\ directory, including any any file
3. reinstall HeidiSQL

That should help against version conflicts in files, especially an old libmysql.dll which could cause the AV here.
vgug posted 8 years ago
Tried uninstall and even on another machine. Nothing worked.

Something changed during my computers down time at the main server.

No other SQL program works either, on a windows or mac system. Back to PHP...

Maybe I'll be able to use Hedi again at sometime. Thanks for all the help anse.

ansgar posted 8 years ago
Could you post your my.cnf / my.ini from your main server so I can take a look for strange settings?
ansgar posted 8 years ago
Btw, what's your server version?
rosenfield posted 8 years ago
I checked out the v4.0 tag from http://heidisql.googlecode.com/svn/tags/4.0 and did a build_everything + install_ide_components, then I started the application within Delphi, suspended it, and used the Disassembly view to get a source code line for the exception you reported. $00669A5A corresponds to somewhere half-way inside line 1832 in helpers.pas:

helpers.pas.1832: result := TStringList.Create;
00669A59 B201 mov dl,$01

Doesn't make much sense. Maybe I'm doing something wrong, or maybe you were using something else than the 4.0 release, like a nightly build? Either way, open a bug on http://bugs.heidisql.com/ and report the exact revision number along with the failing address, and I'll have another look.
vgug posted 8 years ago
Sorry anse but I couldn't get the information you requested, the hosting company wouldn't give it out.

here is an image of the version and error.

My main web guy was on the phone with them for almost an hour then had to wait for them to call back and still get the error. Though I am able to do what I need to with PHP which takes about 20 seconds longer.

I did however attempt to connect to mysql site for another website I own and it connected beautifully! So I might be able to use Hedi at some point again.

Please login to leave a reply, or register at first.