Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Session manager

alfiqmiq's profile image alfiqmiq posted 8 years ago in Feature discussion Permalink
In session manager we can find field databases: separated by semicolon my suggestion is to allow multiselect with ctrl or something like that, now we can select only one position, and other we have to add manually by enter their names separated by semicolon.
alfiqmiq's profile image alfiqmiq posted 8 years ago Permalink
Any answer for my suggestion?
ansgar's profile image ansgar posted 8 years ago Permalink
Yes, I guess pressing Ctrl when selecting a db should be doable.
Code modification/commit from ansgar.becker, 8 years ago, revision 4721
Turn combobox for databases in session manager into a drop down menu, and allow multiple checked items. See http://www.heidisql.com/forum.php?t=15081
ansgar's profile image ansgar posted 8 years ago Permalink
Done in r4721

It's now a drop down menu with check support for multiple selected databases.
alfiqmiq's profile image alfiqmiq posted 8 years ago Permalink
great job - thanks
ansgar's profile image ansgar posted 8 years ago Permalink
r4722 enhances this drop down with a connection cache, so not every click opens a new connection to the current server parameters.
Efim's profile image Efim posted 2 years ago Permalink

hi. The problem of choosing a database. It doesn’t happen to use a semicolon. Error on the screen (Windows version of Russian. It says "the database does not exist"). There is no selection from the list menu of several entries.

Description Description

ansgar's profile image ansgar posted 2 years ago Permalink

I can confirm that for PostgreSQL, while it works with MySQL and MariaDB, with checkboxes in that dropdown menu. You should report that in the bug tracker.

Sunbird37's profile image Sunbird37 posted 8 months ago Permalink

Still having this problem in HeidiSQL 11.3 and PostgreSQL.

I cannot select multiple databases in the drop menu. If I use semicolons to manually enter multiple databases I get the same error reported by Efim.

Any workarounds ? Can I bypass this UI and force this parameter somewhere ?

ansgar's profile image ansgar posted 8 months ago Permalink

You can't, in PostgreSQL mode. That "Database" (not "Databases" by the way) is used in the connection string, and has to contain a single database, like documented: https://www.postgresql.org/docs/9.4/libpq-connect.html#LIBPQ-CONNSTRING

Sunbird37's profile image Sunbird37 posted 8 months ago Permalink

Indeed, I did not see that the database field's label turns to singular when PostgreSQL is selected. My bad.

However I was lead into error by the placeholder text "Separated by semicolon" of the "Database" field. I though it meant that I could enter multiple databases names.

image description

ansgar's profile image ansgar posted 8 months ago Permalink

Oh yes, that's of course an issue. Will change that text hint into something different.

Code modification/commit 829b89d from Ansgar Becker <anse@heidisql.com>, 8 months ago, revision 6373
Fix misleading text hint on databases input in PostgreSQL mode. See https://www.heidisql.com/forum.php?t=15081#p38577

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.