How disable Warning popup ?

asneg posted 2 years ago in General

How disable Warning popup after every query ?

lukinhaspm posted 2 years ago

if you are using MySQL, use ' ; ' every time in the end of your SQL statement! In my case, its works in several times, otherwise, review your SQL statement.

asneg posted 2 years ago

I know Warning problem, but query is work. And i don`t wont see every time this popup. 10000 times a day.

Simpe write Warning message to console. For what this crazy popup ?

lukinhaspm posted 2 years ago

show us a print

asneg posted 2 years ago

print

1 attachment(s):
  • Capture
lukinhaspm posted 2 years ago

How about the messages? make some sense?

asneg posted 2 years ago

Good idea - all error show in errors console or main console - without popup. Like all professional editors.

Syntax Bug messages - good popup. Warnings popup - bad popup. Query works fine but Popup 10000000 times at day popuped.

Simple make checkbox at options - Disable warnings pop. 10 others SQL editors dasn`t have this . Its 10 minutes works.

lukinhaspm posted 2 years ago

Well, it's good idea, but its not commom. I use Heidi a long time and I haven't this problems.

asneg posted 2 years ago

How show warning text ? What warning problem ?

Popup show only number of warnings.

rebelde posted 2 years ago

I have to agree with the OP here. I would REALLY like the option to have warnings sent somewhere else other than a popup.

I have a snippet with a series of statements to create a new table.

I use:
CREATE TABLE temp.table2 LIKE temp.table1;

instead of
CREATE TABLE IF NOT EXISTS temp.table2 LIKE temp.table1;

Why? Because an error (when the table already exists) can be set to fail with a line in the console, but the warning popup produced by "IF NOT EXISTS" is annoying.

Again, thanks for the great product that I really appreciate and have donated to. I just think that having this option would make it better.

ansgar posted 2 years ago

Did you already disable the "Stop on errors in batch mode" option, the button with the yellow warning sign on the main toolbar?

rebelde posted 2 years ago

Thanks. I guess that is what I need to do. I think there might be a good reason that I wanted it to stop on errors. I will try this and see if it gets me into any trouble.

By the way, HeidiSQL has been crashing an awful lot for the last few months. If there is anything I can do to help troubleshoot this, let me know.

josebrwn posted 6 days ago

Gotta agree with OP. "Stop on errors in batch mode" reduces the occurrences of critical stops but they nontheless continue so often during development it renders HeidiSql virtually unusable. I've never encountered an IDE of any kind that does this.

ansgar posted 6 days ago

Ok, so you have disabled that "Stop on errors in batch mode" but still you get warning popups? When exactly do you get one, for example?

Please login to leave a reply, or register at first.