Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Column width resets

Cpecific's profile image Cpecific posted 7 months ago in General Permalink

When I connect to, say, "Session Localhost", then change columns width to my preference, heidi saves widths and works fine. If I connect to "Session Localhost" again it will be ok, but sometimes some columns will be a little bit bigger than I set them to.

But when I connect to different session, "Another Session", column width resets and becomes ultra wide. Sometimes it just reset some of them, and every time width is different.

This visual bug is super frustrating and is getting on nerves big time. I haven't encountered this in previous versions.

2 attachment(s):
  • css-columns
  • css-columns-reset
ansgar's profile image ansgar posted 7 months ago Permalink

You are using HeidiSQL in high DPI mode, which is causing these wide columns. High DPI modes are not supported in HeidiSQL, due to a large amount of issues that introduced.

I also suppose this is an old version, you should upgrade.

Cpecific's profile image Cpecific posted 7 months ago Permalink

But heidi does support High DPI (just checked it). As I said already, I am using the newest version.

ansgar's profile image ansgar posted 7 months ago Permalink

Latest release v11 comes with disabled High DPI support, so you may have activated it yourself, by modifying the taskbar shortcut to it.

As said, there are many issues with that, and the column width problem is one of these. That's why I gave up supporting high DPI modes.

Cpecific's profile image Cpecific posted 7 months ago Permalink

Re-checked it on 4k display and understood that you are kinda "right".

So you don't introduce confusion later when someone else brings up this topic: you don't have High DPI enabled, but you have upscaling to High DPI level.

Then I have another question, how the hell is there a bug with column width, even though you just upscale layout?

ansgar's profile image ansgar posted 7 months ago Permalink

I don't think there is a bug. I think your screenshots are taken from an older release, or you configured your HeidiSQL task button with overridden High DPI support. Upscaling looks different (blurry).

This is your screen:

Description

this is from mine, just upscaled to 150% DPI:

Description

Cpecific's profile image Cpecific posted 7 months ago Permalink

You wouldn't see blurrines on 125% and if I had High DPI enabled (as you mentioned earlier) I would acknowledge it. I have never even touched the settings, lest talk about shortcut with arguments.

ansgar's profile image ansgar posted 7 months ago Permalink

And which HeidiSQL version is it?

Cpecific's profile image Cpecific posted 6 months ago Permalink

11.0.0.5949

ansgar's profile image ansgar posted 6 months ago Permalink

Ok, and when you rightclick your HeidiSQL icon on the taskbar, then click properties, then click on the "Compatibility" tab, and then on "High DPI setting", what do you see there?

Cpecific's profile image Cpecific posted 6 months ago Permalink

I guess it is default windows settings. I tried to uncheck windows settings (2nd pic) but nothing changed.

I managed to disabled high dpi when I unchecked checkbox at the bottom (1st pic). I guess it solves my problem.

2 attachment(s):
  • dpi-info
  • dpi-windows
ansgar's profile image ansgar posted 6 months ago Permalink

Default for the second checkbox is unchecked:

Description

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.