Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

The maximum column size is 767 bytes

serlopsil's profile image serlopsil posted 1 month ago in General Permalink

Good afternoon,

I am trying to import a MariaDB database. The database is from a Wordpress Multisite, about 800mb of capacity.

The issue is that I get this error: SQL error (1709): Index column size too large. The maximum column size is 767 bytes. Note: You can disable the "Stop on errors in batch mode" option to ignore such errors.

How could I fix this problem?

Thank you very much!

ansgar's profile image ansgar posted 1 month ago Permalink

https://stackoverflow.com/questions/42043205/how-to-fix-mysql-index-column-size-too-large-laravel-migrate

serlopsil's profile image serlopsil posted 1 month ago Permalink

Thank a lot! I see that I have to change:

Set default collation in my.ini: collation_server=utf8_unicode_ci character_set_server=utf8

Do I have to change this in the MySQL configuration of my hosting? Is it true?

Thank you very much for your answer Ansgar!

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.